• Register
  • Help
Results 1 to 10 of 10

Topic: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

  1. #1

    No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    If I create a new project from scratch, I can use Aria as an AU inside Logic 9 with no problem. If I open a Logic 7 project, I also have no problem. However, if I open a MID file created in Logic 7, turn it into a Logic 9 project, and then try to use Aria, I get no sound.

    These are midi files that I created, so there shouldn't be any permissions/rights issues. I can use all other audio units successfully.

    Sometimes I can click on the keyboard within the Aria window and get sound, but that still doesn't translate to the track playing.

    I've tried saving individual tracks as MID files and then importing them into a new project, but I still have the same problem. That's also the case if I copy the notes and paste them into a new project. (?!)

    I've tried opening the AU Manager and rescanning the AUs. That sometimes allows me to click on the Aria keyboard and get sound, but I still can't play the tracks.

    I've checked the Event List to make sure that there's no hidden volume settings or other controls that would cause this. I've removed any inserts that may show up. The tracks aren't greyed out or muted, and none of the other tracks are soloed.

    This problem occurs with more than one file. (*Many* more!)

    I originally had this problem using Leopard. Then I wiped my hard drive, installed Snow Leopard and reinstalled everything else from scratch. I also replaced the logic board in my Macbook Pro, which makes up roughly 90% of the innards.

    I'm using Aria/GPO 4.02, OS X 10.6.4 and Logic 9.1.2. Any ideas? Thanks in advance.

  2. #2

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    I'm not really sure, but did you try setting the mod wheel (CC 1) to some higher value (e.g. 64). The issue cannot be importing MIDI files created in one version into another version, but it might be that Logic sets the mod wheel to 0, whereas it keeps the value when you import a whole project.

  3. #3

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    Have you tried to open up the Logic 7 Song directly in Logic 9? Seem to me you are taking a few unnecessary steps.


  4. #4

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    Thanks for responding. My apologies for the delay in getting back to you. (I thought I'd receive email notification of replies, but I guess not.)

    FLWrd: I've deleted *all* data from the track other than notes and program by using the Event List. The Mod Wheel is in its default position in Aria. I tried moving it around with no change in the results.

    robh: My apologies if I wasn't clear in my original message. Everything is being opened in Logic 9. I don't even have Logic 7 installed.

    To all: Please note that using any other AU will work just fine, as will any of the instruments that come bundled with Logic 9. Aria is the only AU/instrument that won't play.

    Any other ideas? All suggestions welcome!

  5. #5

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    robh: I just reread everything, and it dawned on me what you really meant. Sorry!

    The project was originally saved as a MID file. When I brought the MID tracks over into Logic 9, there was no way to continue to save changes as midi. That's when I saved the tracks as a Logic 9 project. There are 3 tracks in the song thus far. All play with anything other than Aria.

    I have this same problem on other ancient projects that were originally MID files as well.

  6. #6

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    Hm. The only other thing that comes to mind is to double check that the MIDI channels on each track match the MIDI channels of the sounds you want triggered within the GPO instance.

    I do have another idea where I could help, but let's see if this is the problem first.


  7. #7

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    Thanks for the idea, robh.

    I brought over another old MID song last night into Logic 9. This one *does* work with Aria. (?!) So, following your suggestion, I compared the differences with how the channels were set up. The channel numbers are both set to the track numbers, but the way things are set up are definitely different.

    When I right click on a track name for the song that *doesn't* work with Aria, and go to 'Reassign Track', I see Click & Ports, Midi Instr, and Mixer. The Software Instrument channels are assigned under the Mixer section (which seems strange).

    When I do the same thing with the song that *does* work with Aria, I see 'Audio' and 'Clicks & Ports'. 'Midi Instr' and 'Mixer' are missing. The Software Instrument channel is assigned under the Audio section.

    I've tried creating a new Audio track in the song where Aria doesn't work. I've also tried creating a new Software Instrument track. Neither one gives me the Audio section under 'Reassign Track' that I get with the song that does work with Aria.

    I know that this is probably something very basic, but there are areas of Logic where I'm still a newbie. How do I get an Audio section under 'Reassign Track'?

    Thanks in advance!

  8. #8

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    Well, I could try to describe what to do, but then both of us will be shooting blind so to speak. If you are willing to send me an email with one of the problem MID files attached (you can easily find my email on my web site), I'll see what's going on and then help you figure out what to do next.


  9. #9

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    Thanks for the file, Aspiring.

    Your problem is very simple to fix - you'll probably kick yourself!

    I opened up the ARIA player and you show Viola 1 Solo in the first slot with a MIDI channel of 1. On the far left of the Logic screen, you should have the "inspector" window open (That's the part with the two faders on the bottom.) If you click the drop down triangle next to the track label "Orchestra Viola Section," you should see more detail, like Icon, Core Audio: Inst 3, and the next detail is the important one; MIDI Channel: All. What this means is that the MIDI data in the region will play through to the instrument as inputted. If you change this to any other value (1-16) the data will play only on that channel selected regardless of what channels are in the region. Now if you check the event list or the score for that region, you will notice that all the MIDI data is actually on channel 3. This means the MIDI data is definitely going into the ARIA player, but it is triggering the third slot set to channel 3, which has no instrument loaded = no sound!

    So you have four ways to fix it:
    1) Change the MIDI channel value in the inspector from "All" to "1"
    2) Change the MIDI channel in ARIA for that first slot from 1 to 3
    3) Put the Viola instrument in the 3rd slot of the ARIA player
    4) Select all the data in the score or event window and change the MIDI channel from 3 to 1.

    You'll have to decide based on the work flow you are most comfortable with. Personally, I do the first one. It's by far the easiest and it fits my workflow.

    If I haven't been clear on something, ask away!


  10. #10

    Re: No sound from Aria/GPO 4 in Logic 9 for Logic 7 midi files

    You rock, Rob!

    You're right, it was ridiculously simple. I'd deleted all event data other than the notes and the Program setting. Unfortunately, my ancient midi files all used the program line to set the midi channel to "all". Dunno why, but these files are from 1985, when midi was a baby.

    My other AUs, not being multi-channel, all automagically set the midi channel to 1, which is why they weren't affected.

    I hope this solution helps someone else down the road. Thanks for sticking with me and helping me to see the obvious.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts