• Register
  • Help
Results 1 to 8 of 8

Topic: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

  1. #1

    Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    Hi, AspiringCarbon is a new member to the forum and she had difficulty posting the following, so I have posted it here for her - Any help will be appreciated...

    Error - Cannot connect to engine
    I have a Macbook Pro running 10.6.4. I use GPO 4 with Logic 9.

    I had to erase my hard disk and am working on reinstalling everything. I
    made the mistake of installing the latest Aria engine update *before* I
    installed GPO 4 from disk. When I realized my mistake, I installed the Aria engine again, after the GPO installation was complete. When I launched Logic, I got this message:

    "Garritan ARIA Player

    Cannot connect to engine, please re-install."

    I deleted the Aria Player, GPO 4, and the "com.Garritan.ARIA Player.plist"
    preference file. I reinstalled the Aria Player and GPO 4.

    I still got the same error.

    Since the Aria engine I installed was a beta, I thought that it might be the problem. I deleted everything again, reinstalled GPO 4 and then installed the most recent stable version of the Aria engine.

    I still go the same error. I deleted everything again.

    Then I found and downloaded and installed the GPO 4.02 update, as well as the Mac Garritan Aria Player and engine package. I still got the same error.

    Then I tried repairing permissions. I still got the same error.

    Any suggestions? Maybe there's some files I can delete to truly get a fresh install?

    I really don't want to go through the 6+ hours it takes to install Logic 9 again. And I've got a project due.

    Thanks in advance for any help you can provide!

  2. #2

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    I would think that support for Garritan products would be your best solution. Have you contacted Garritan Support for assistance?

    My only thought (other than the one stated above) is if you re-entered your license signature file after re-installing ARIA and GPO4. If that were corrupted or not entered, maybe that would be what is causing this error message. I think your license is always available at the Garritan website, but (luckily) I have not needed to re-install (at least not yet!).

    Sorry, this is the only thoughts and ideas I have. I am not a MAC user so maybe some Macbook users can jump in and give you a hand.
    [Music is the Rhythm, Harmony and Breath of Life]
    "Music is music, and a note's a note" - Louis 'Satchmo' Armstrong


  3. #3

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    RichR: Thanks for your response.

    I contacted Garritan support back on 10/21. They responded with the following:
    Try reinstalling and also try getting the very latest ARIA update at
    www.ariaengine.com. Do not delete in parts or it may mess things up. Try
    reinstalling and then running the update
    I responded that I'd already done that (twice) & still got the same error. I haven't heard from them since.

    I'm unable to enter my license at all. Attempting to open the Aria Player to drag my product key image onto it results in the same error. Dragging my product key onto the closed icon also gives me the same error.

    I called Garritan just now and got an answering machine. I've left a message. Hopefully, someone will respond, although their message makes clear that phone calls take longer for them to respond to than emails.

    To everyone: Are there perhaps files put in place by the original ARIA engine installation that I can delete to fix the problem? Or any other ideas? Thanks in advance!

  4. #4

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    Gary Garritan himself called me back with lightening speed. Unfortunately, I've already tried all his suggestions. At his request, I ran the Aria Player report and sent it to him, along with all the details of my problem. I know he's very busy with more important things right now, so if anyone else has suggestions, feel free to add them. Thanks!

  5. #5

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    If this was a Windows system I would suggest using a program like CCleaner to clean the regestry (removing certain left over files from previous installs).

    I googled registry cleaning for Mac, and found this article that explains how to do it using the Mac Disk Utility application.


    After uninstalling ARIA, you might try doing this... but your best bet is to wait to hear back from the bug report.

    Also, consider trying both 32 and 64 bit versions of ARIA. I don't know what the underlying problem is, so these are just a couple of general troubleshooting possibilities.
    "If a man does not keep pace with his companions, perhaps it is because he hears a different drummer. Let him step to the music which he hears, however measured or far away." – Henry Thoreau

  6. #6

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    Hi Tim! Thanks for your suggestions.

    I tried using Disk Utility in every combination and at every step I could think of. I used it after install, and then restarted. Then after restarting. Etc. Unfortunately, it didn't change anything. My experience over the years has been that Disk Utility only repairs permissions. I.E., I have yet to see it actually delete a file. But it was worth a shot!

    I can't find a 32 bit version of the Aria engine anywhere. The current architecture is 64 bit, although I did find references to an older dual install that included a 32 bit version. Finding the 32 bit version may be pointless, however...

    I'm looking through the logs that the Aria reporter creates. Nearly all of the install logs look good until this last line:

    CFBundleGetFunctionPointerForName failed for ariaOpcode

    I'm looking at some other logs that may provide some clues. I'm no expert, of course, but one of the Aria installs, or a portion of one, seems to have been unable to find the version or location of the VST and AU plugins. This is strange, since the same log seems to show that the install program was able to find the version and AU plugin with no problem. But even that search failed to find the VST plugin, which was sitting exactly where it should be, in the same parent folder as the AU plugin. ?

    I was going to uninstall and reinstall Logic, but this info suggests that would be pointless. (And a waste of 7 or so hours of my time.)

    I'll continue trying to make sense of the logs. If anyone has ideas regarding this, please feel free to let me know. Thanks!

  7. #7

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    PROBLEM FIXED!!! (Yea!)

    Here's the details, in case it helps anyone else who might come along. I'm including things that are obvious to most of you, but newbies need every bit of help they can get.

    Went to (Hard Drive Name)/Applications/ and deleted the folders for:

    Garritan ARIA Player
    Garritan Personal Orchestra 4

    Went to (Hard Drive Name)/Library/Audio/Plugins/ and deleted the Aria AU and VST plugins.

    Went to (Hard Drive Name)/Library/Application Support/ and deleted the Plogue folder.

    Went to (Hard Drive Name)/Library/Preferences/ and deleted:

    com.Garritan.ARIA Player.plist
    com.Garritan.Personal Orchestra 4.plist

    Went to User/Library/Application Support/ and deleted the Plogue and Garritan folders.

    Went to User/Library/Preferences and deleted:

    com.Garritan.ARIA Player.plist

    I then did a system wide search in Finder for the following words to ensure that nothing was missed:


    Then I ran Disk Utility to repair my permissions, restarted the computer, ran Disk Utility again ('cause I'm paranoid!) and installed Aria Player and GPO 4 from my install DVD.

    When that finished, I successfully launched Aria Player and dragged my Garritan product key image (a .png file) from my desktop onto the words "Aria Player" at the top of the Aria Player application. A popup confirmed that the product was now registered. I confirmed that I could launch GPO 4 within Logic 9, which I could.

    THEN I ran the MAC_Garritan_Personal_Orchestra_4.02_Update. Everything looks good now.

    Thank you, thank you, thank you to all of you who tried so valiantly to help me. I appreciate it!

  8. #8

    Re: Thread posted from new member AspringCarbon seeking assistance for GPO4/ARIA ASAP

    Very pleased to hear you sorted it out AspiringCarbon!

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts