• Register
  • Help
Results 1 to 2 of 2

Topic: Unable to update Omnisphere software to 1.3.1c

  1. #1

    Unable to update Omnisphere software to 1.3.1c

    Apologies if this has been covered already, but I am unable to update Omnisphere to v 1.3.1c. It remains as v 1.0.3f.

    I recently downloaded the update to 1.3.1c and installed it. I rebooted my PC and opened my host (Sonar). I then inserted Omnisphere. After clicking on the Spectrasonics logo I noticed that the software remains as 1.0.3f. However, I then realised that there have been several other software releases since 1.0.3f, which I hadn't installed.

    These are (according to the Omnisphere software version history) : 1.0.4g, 1.0.4h, 1.0.4i, 1.1.3c, 1.1.4c, 1.2.0n and the latest, 1.3.1. Unfortunately, I did not download all these releases when they came out. The ones that I did download have not yet been installed.

    My question is, do I have to install ALL the above successive software releases to get to v 1.3.1c ? If so, where do I get the ones that I am missing ?

    I will add that I installed 1.0.4g, which is the next release after 1.0.3f, and Omnisphere is still showing as 1.0.3f. So the update to 1.04g has not worked.

    If anyone can suggest how I can go about updating my software through all the above releases and up to and including 1.3.1c, I would be most grateful. I will add that the patch library and soundsource library have been updated to the most recent versions, but not the software !

    Thanks for your help


  2. #2

    Re: Unable to update Omnisphere software to 1.3.1c

    OK - I've worked out how to do it ! For anyone else out there that has had the same problem, you need to run the Cakewalk VST update manager (if using Sonar), to rescan the new (updated) dll. On re-inserting Omnisphere, it now shows the software as being completely up to date.


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts