• Register
  • Help
Results 1 to 3 of 3

Topic: Spectrasonics Plugins Playing Up

  1. #1

    Spectrasonics Plugins Playing Up

    I have used Stylus RMX for several years now and never had a single issue with it. I has worked so reliably until I decided to buy Omnisphere and Trilian. Now it is a whole different story and is like driving a car with 3 naughtly kids in the back seat - at least one of them is playing up or sulking at any one time.

    Currently I cannot load Stylus RMX 1.8.0.d or Trilian 1.1.4c. They show up as unloadable in the Cubase plug in list. I have tried re-installing them and even re-installing Cubase but all to no avail. I am using Cubase SX3.1.1 on Windows XP SP3.

    As it is I am going to miss a project deadline. Can anybody suggest anything to get me back up and running please?

    Many thanks.

  2. #2
    Senior Member playz123's Avatar
    Join Date
    Jan 2007
    Victoria, Canada

    Re: Spectrasonics Plugins Playing Up

    I don't see any mention of your hardware specs, but I would suggest that's it's really time to consider updating your host, in order to keep up with newer technology. SX3 is way back there now and, for example, you'll need a newer version of Cubase to run Omnisphere 1.2. Anything from the past few years, like Cubase 4 or 5 will do...........playz
    Cubase 7.0.3, Wavelab 7.1, Omnisphere, Trilian, Stylus RMX, Symphobia 1 & 2 , all Spitfire libraries, LASS 2, Requiem Pro, Voxos, Superior Drummer 2, Komplete 8, Cinematic Guitars, most EW libraries, Chris Hein Horns, Guitar & Bass, 2.8 GHz Mac Pro, 18 GB RAM, OS 10.6.8, RME Multiface II + HDSP PCIe

  3. #3

    Re: Spectrasonics Plugins Playing Up

    I think the specific issue is that Trilian and Omnis are vst 2 instruments and SX 3 is not a vst 2 host. You really should update as SX 3 is entirely antequated compared to whats in Cubase 5.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts