• Register
  • Help
Results 1 to 10 of 10

Topic: Problem saving in 2.0 and 2.1

  1. #1

    Unhappy Problem saving in 2.0 and 2.1

    I've been using Notion since it came out. I upgraded to Notion 2.0 and brought up a score I had created in the previous version. As I made changes I saved at various intervals. When I was done I saved again and hit "Close". Notion prompted me to save my work. I hit ok and it returned me to the document I was trying to close. After trying this several times I did a "Save as" but when I tried to save that document it said it was opened "Read only". I also tried hitting "Don't save" but when I did that I lost all the changes after the original opening of the document, even though I had saved many times.

    Thought it was a one-time thing, but it happened many times after that. Finally adopted the strategy of closing the document after just a few changes instead of just saving and going on. That works most, but not all of the time.

    Tried upgrading to 2.1 but still the same problem.

    Sent the score to Tech Support but they say they can't reproduce the problem.

    Anyone else having this problem?

  2. #2

    Re: Problem saving in 2.0 and 2.1

    What's your OS?
    Admin or general user account?

    Prior to v2x I had issues after a save-as the the original file was still in the game. V2.1 has been stable here. I regularly incrementally save-as name 1.1, 1.2, 1.3 etc...

  3. #3

    Re: Problem saving in 2.0 and 2.1

    I'm on XP sp 2

    I'm the admin on the PC.

    I save as v1, v2 etc. also, but after making some changes over an hour or so I'm unable to save the document as described in my original post.

  4. #4

    Re: Problem saving in 2.0 and 2.1

    This may seem like a silly point, but was the file in a folder on your hard drive, or could it possibly have been on a CD? Any chance there were multiple versions of the file saved in different locations, and the one that was open was on a storage device that doesn't allow direct writing (such as a CD)?

  5. #5

    Re: Problem saving in 2.0 and 2.1

    There is no cd involved. BTW I'm a computer programmer so I'm very aware of basic issues. It looks to me like the 2.x version of Notion doesn't actually save anything to the hard drive until you do a File/close. This is a very bad idea and is going to result in a lot of lost work for composers unless they change it. Using this kind of scheme means when you do a File/save or click the new Save button Notion isn't actually writing your file back to the hard drive...instead it is storing your file in a temp file somewhere or in memory. If something goes wrong before you finish up and hit File/close you will lose all your work even though you think you've "Save"ed it.

    I reported this to Notion's tech line and sent them one of my files. They say it must be something to do with my particular PC since they can't reproduce it there. I doubt it. Not being composers I have no idea what types of changes they are making to the file before trying to save and close it. But I doubt this problem is only on my PC, which is a pretty standard HP machine running XP SP2. I didn't have this problem until I fooolishly upgraded to 2.0 and got the problem and then to 2.1 hoping it would fix it, which it didn't.

    Notion hotline says no one else has reported this problem. As a very experienced computer programmer of many years standing I can only say that I've heard that one before from numerous hotlines at my job and it means nothing since the 2.x version is fairly new and not that many people have upgraded. In the future I won't be one of the first. I'm sure as time goes by they'll get many others and finallly have to address the issue. If it is due to some aspect of my PC configuration I'm sure I'm not alone in this.

    Meanwhile, what to do? I'm loathe to dump Notion since it's a very good composing environment for me, but I can't keep losing work. I guess I'll re-install it as the hotline suggested and see if that fixes things. Any other ideas? Anyone else with this problem?

  6. #6

    Re: Problem saving in 2.0 and 2.1

    Re-installed Notion and the problem is still there.

  7. #7

    Re: Problem saving in 2.0 and 2.1

    I find this very interesting... I've been working with notion a ton in the last couple of weeks... 2.1.1 or something like that... I've had no problems, of course I'm running it on two intel macs, I haven't tried it with a pc. However, if what you say is true about it only storing in memory till you close the program... that is really something that needs to be fixed.

    sorry to hear you are having some many issues... I love this program, as I'm sure when it's in working order you do as well. Good luck with it, I've been sending emails about wanting to rid myself of the dongle... I get daily replys, they are good about getting back with you.

  8. #8

    Re: Problem saving in 2.0 and 2.1

    Actually I have to eat some crow here. I tried saving a Notion document without closing the document, looked in Explorer and found that the time stamp on the file had changed. I did some more work then saved again. Time stamp changed again.

    This indicates I was wrong about it not saving to the hard drive when you click "Save". But then how do you account for the lost data when I get the problem described above: I try to close the score and get prompted by a box that asks: Save, Don't Save, Cancel. When I pick Save the document remains open. When I click Don't Save the document closes but all my changes all the way back to the open of the document are lost.

    If, indeed, Notion is saving to the disk when you click "Save" why do I lose my work under these circumstances since I've already saved it?

    It's very perplexing.

  9. #9

    Re: Problem saving in 2.0 and 2.1

    Quote Originally Posted by RogerR

    If, indeed, Notion is saving to the disk when you click "Save" why do I lose my work under these circumstances since I've already saved it?

    It's very perplexing.
    I don't have Notion installed, but it strikes me as peculiar Windows behavior that clicking Save in that dialog would not close the document after saving. This suggests to me that the command isn't working at all, neither for saving nor for closing the document.

    Do you have any experience with writing UI's for Windows applications? I personally don't, but I'm thinking that particular dialog and that functionality is common enough that it's probably something they're using a standard Windows library for. Perhaps you have a different version of a .dll file that's being used for this? That might explain why others aren't seeing it. Perhaps Notion is using a .dll file that they are relying on being pre-installed on the system rather than including all the dll's Notion uses?

  10. #10

    Re: Problem saving in 2.0 and 2.1

    I'm now pretty clear on what's going on but don't why it happens.

    When I save, it usually does go to the hard drive, but then, all of a sudden, it doesn't save to the hard drive...yet no error message is produced. It simply doesn't save to the disk. I figured this out by monitoring the timestamp on the file every time I saved.

    Once it doesn't save, it will not subsequently save again and when you try to close the file it won't close unless you click "don't save".

    I still find it hard to believe I am alone in this. Perhaps it has something to do with the fact that I imported from XML to create the original document and it introduced some kind of problem into the file.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts