• Register
  • Help
Results 1 to 6 of 6

Topic: Observations

Share/Bookmark
  1. #1

    Observations

    I am in the middle of getting to know Garritan and I noticed some strange behaviours.
    ------------------------------ A -------------------------------------
    Using a violin part of two voices, sometimes "divisi" and sometimes "unison".
    There are two instances of Garritan, named 1stViolins-voice-1 and 1stViolins-voice-2. Both have the same instruments from the library, but with some slightly difference in volume and sample lenght and portamento.

    For the slow parts (long notes) I used violins lush. So far so good, but the sound isn't quite what I expected (tiny bit of distortion). Now I changed one of the voices to violins short bows and the improvement is noticeable.

    This distortion only happens with two violins lush.

    ------------------------------- B -------------------------------------
    I also have the 2nd violins in that piece and they too play sometimes "divisi", so I did the same with this section. I loaded two instances of the Garritan 2nd violins and set both to 2nd violins lush, etc. So the divisi parts for long notes both play the same samples from different instances of Kontakt Player.

    Now the distortion is really noticeable and sounds like "keyhole music" . Changing one of the voices again to 2nd violins short bows, makes it disappear.

    ------------------------------- C -------------------------------------
    I've set pedal markings in the score under the violins to later do the legato as Tom H. suggested in another message. I lenghtened the notes until they overlap (by the way overlapping in the sense that the note goes over the beginning of the other isn't really necessary. As long as they end where the other begins we can apply legato (in the sense that more notes are to be played in one stroke of the bow).

    Suppose a bar with C4 (two beats) and D4 (two beats), no pedal markings, no legato. Next bar starts with G5 and under the score there is a pedal marking to indicate the legato for the next notes (e.g. Gb5, F, E).

    When I have that pedal marking right under - and starts at the same time as the G5 does - the G5 I noticed a glitch at the start of G5 (1st violins lush).
    Shifting the pedal mark one beat (or some ticks with Sonar) to the right makes the G5 as it should. There are other occasions an unexpected "glitch" occurs. When that happens I first had a look at the staff view and shifted the pedal mark a bit. This happens not ALL THE TIME. Only when the notes are far away from the last one.

    ------------------------------- E --------------------------------
    I had hoped that the "automatically alternating up- and downbows" had a greater span, but they are very short. IMHO too short. I used to play the cello (sorry, but only for two years) and can remember that sometimes I had to really give the bow a fierce stroke (and speed) to "span" the length of a 2 beats notes in a 4/4/ bar with tempo 80.

    -------------------------------- F ------------------------------
    It is a rainy day with a lot of wind, so I'll stay at home and go on with .... what ever I was doing :-)

    Have a nice sunday folks,

    Raymond

  2. #2

    Re: Observations

    Here's a couple of things that may help.

    Quote Originally Posted by Raymond62
    For the slow parts (long notes) I used violins lush. So far so good, but the sound isn't quite what I expected (tiny bit of distortion). Now I changed one of the voices to violins short bows and the improvement is noticeable. This distortion only happens with two violins lush.
    Not having heard the actual distortion, I have to make a guess here. It is most likely that you are overloading some part of your signal chain. Your primary suspect should be the GPO player itself, but I don't know how you are using it. Are you using GPO as a VST inside a sequencer? Are both instances of Violin 1 in the same instance of the same player on different channels, or in two different instances? What volume level are you using?

    I have found that it is not difficult to push the volume of instruments high enough to distort within the player, especially if you have filled up several channels on that instance, and each instrument is playing forte or fortissimo. Try backing down the MIDI volume of everything, and boost the output level within your sequencer. You can always check your levels by setting CC#1 to your highest intended values on all instruments, and putting in some test chords. Then slowly back down your MIDI volume until there is no distortion.

    When I have that pedal marking right under - and starts at the same time as the G5 does - the G5 I noticed a glitch at the start of G5 (1st violins lush).
    Shifting the pedal mark one beat (or some ticks with Sonar) to the right makes the G5 as it should. There are other occasions an unexpected "glitch" occurs. When that happens I first had a look at the staff view and shifted the pedal mark a bit. This happens not ALL THE TIME. Only when the notes are far away from the last one.
    This is actually an "expected glitch." The CC#64 message should definitely be after the start of the initial note in the legato series. I'd give it a nice margin just to be safe.

    I've also found that at very high latency settings the legato gets choppier and choppier. In order to get it to function properly, latency should probably be in the range of 5-20 ms, depending on your overall set-up.

    I had hoped that the "automatically alternating up- and downbows" had a greater span, but they are very short. IMHO too short. I used to play the cello (sorry, but only for two years) and can remember that sometimes I had to really give the bow a fierce stroke (and speed) to "span" the length of a 2 beats notes in a 4/4/ bar with tempo 80.
    Have you tried the "short+sustained" samples? They might do the trick. I've also had some success with layering the short bow and lush samples.
    - Jamie Kowalski

    All Hands Music - Kowalski on the web
    The Ear Is Always Correct - Writings on composition

  3. #3

    Re: Observations

    Quote Originally Posted by Skysaw
    Here's a couple of things that may help.

    Not having heard the actual distortion, I have to make a guess here. It is most likely that you are overloading some part of your signal chain. Your primary suspect should be the GPO player itself, but I don't know how you are using it. Are you using GPO as a VST inside a sequencer? Are both instances of Violin 1 in the same instance of the same player on different channels, or in two different instances? What volume level are you using?

    I have found that it is not difficult to push the volume of instruments high enough to distort within the player, especially if you have filled up several channels on that instance, and each instrument is playing forte or fortissimo. Try backing down the MIDI volume of everything, and boost the output level within your sequencer. You can always check your levels by setting CC#1 to your highest intended values on all instruments, and putting in some test chords. Then slowly back down your MIDI volume until there is no distortion.
    Also there is a built-in meter in the Kontakt player (upper right side).

    Hannes
    All your strings belong to me!
    www.strings-on-demand.com

  4. #4

    Re: Observations

    Quote Originally Posted by Skysaw
    Are you using GPO as a VST inside a sequencer? Are both instances of Violin 1 in the same instance of the same player on different channels, or in two different instances? What volume level are you using?
    I use the Vst version in Sonar 5 Prod.
    The volume levels in the KP were set to minus 5 dB.
    I didn't load the same instrument into one instance. I used different instances for the different voices. In the KP player I had CC#7/CC#10 disabled.

    I have found that it is not difficult to push the volume of instruments high enough to distort within the player, especially if you have filled up several channels on that instance, and each instrument is playing forte or fortissimo.
    Yes, but in Sonar one can adjust the volumes of each individual instrument easily and for the final touch I use the "bus-type" channel [to indicate the primary out]

    Try backing down the MIDI volume of everything, and boost the output level within your sequencer. You can always check your levels by setting CC#1 to your highest intended values on all instruments, and putting in some test chords. Then slowly back down your MIDI volume until there is no distortion.
    And that I don't like, let's say I hesitate to do so. As a pianist I know that hard hitting the keys gives you another timbre and nuance than a softer touch with amplification. But I experimented with this and found out that it barely had some influence on the overall character of the sound [at least for the violins].

    This is actually an "expected glitch." The CC#64 message should definitely be after the start of the initial note in the legato series. I'd give it a nice margin just to be safe.
    I did and no more glitches (at least not where I don't want them)

    I've also found that at very high latency settings the legato gets choppier and choppier. In order to get it to function properly, latency should probably be in the range of 5-20 ms, depending on your overall set-up.
    I did so and now I have with 384 samples buffer a latency of 8.7 ms. The legato is better now. But the drawback is that now the system gives me some hick-ups and crackles. So I must search for a good balance between the two.


    Thank you both for the answer.

    Raymond

  5. #5

    Re: Observations

    Quote Originally Posted by Raymond62
    I use the Vst version in Sonar 5 Prod.
    The volume levels in the KP were set to minus 5 dB.
    I didn't load the same instrument into one instance. I used different instances for the different voices. In the KP player I had CC#7/CC#10 disabled.

    Yes, but in Sonar one can adjust the volumes of each individual instrument easily and for the final touch I use the "bus-type" channel [to indicate the primary out]

    ...And that I don't like, let's say I hesitate to do so. As a pianist I know that hard hitting the keys gives you another timbre and nuance than a softer touch with amplification. But I experimented with this and found out that it barely had some influence on the overall character of the sound [at least for the violins].
    There is actually an important point here that you may be missing. MIDI volume theoretically has no impact on instrument timbre within GPO, but can definitely distort if too loud for the player internally. That is to say your levels on your busses will offer no help as the signal will be distorted before you get to even touch it.

    You should always use CC#1 (as you probably know) to alter your instrument dynamics for winds and strings. The default MIDI volume level (CC#7) in Sonar is 100, I think. This is much too high for use with high dynamic markings! I set this between 50 and 70, and I get no distortion. At 100 you'll be fine if you stay under a forte marking for most instruments, but eventually you'll be asking for trouble.

    To sum up, here is my recommendation:
    1. Try a value of 50-70 for each MIDI track. This is the blue controller directly under the instrument name on the MIDI track within Sonar, not the volume controller on the Kontakt player.

    2. Use CC#1 to control dynamics for winds and strings, and velocity to control dynamics of keyboard and percussion instruments.

    3. A check of your loudest passage for each instrument should reveal no distortion. If you hear some, go back to step 1 and try a lower value for MIDI volume.

    4. When the balance between instruments is correct, set your overal volume level in your master bus to the proper level.
    - Jamie Kowalski

    All Hands Music - Kowalski on the web
    The Ear Is Always Correct - Writings on composition

  6. #6

    Re: Observations

    Quote Originally Posted by Skysaw
    There is actually an important point here that you may be missing. MIDI volume theoretically has no impact on instrument timbre within GPO
    I wasn't talking about MIDi volume, I meant the final "wave" output.
    The default volume value =101, why I don't know and one cannot alter this default. I already have it set to lower values.

    And for all the other recommandations: I am a very obeying guy and have already set those values, you mentioned, to a moderate level.

    Today is another "experimental day" until it is good enough.

    One idea came to my mind: Garritan offers an online orchestration course. Why not? And it is great stuff. But the best is just "practice it" and you will find out what the sound is. I am struggling to learn Sonar and Garritan at the same time and must say that on the "orchestration level" I learned quite a lot. I recommend everybody to "do" this at home.

    Have a nice day,

    Raymond

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •