• Register
  • Help
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Topic: Finale/Sonar Users .. How do you .. Volunteers to test File

Share/Bookmark
  1. #1

    Finale/Sonar Users .. How do you .. Volunteers to test File

    Forgive me for starting a new thread on an issue I already raised. I feel the previous thread has run its course, all suggestions tried and I am trying a new approach. Things are not good

    I shall come on to the issues in a moment but first, a general request if there are any Finale/Sonar 5 users who are willing to help by trying a test organ Chorale file I have made, I have put all the permetations of the file up for anyone to download and experiment with. I must stress that this is NOT a serious arrangement, it is purely for testing organ patches. The files are Finale 2006, MIDI and Sonar 5. The link is at the end.

    I have been in dialogue with Tom Hopkins, Robert Piechaud and Markleford on thie issue described below. For those non Finale and Sonar users, Robert wrote the superb 'Human Playback' feature in Finale and Markleford is an experienced, knowledgable Sonar person.

    My Writing Process:

    My music is prepared as a score in Finale 2006c using 'Human Playback. The file is saved as a MIDI file then imported into Sonar Producer 5 for mixing and adding effects. When I have the right mix and sound, I then export the finished music to audio ready for burning to CD.

    The Issue:

    Having mixed and balanced my file in Sonar using the Console (mixer), when playing back, the file ignores my mixer settings. In order to get my mix back, I have to 'nudge' the sliders of the mixer during playback. This makes it impossible to export my file, as I have balanced it, to audio.

    Cause of the Problem:

    Markleford, looked at a test file I prepared and identified the problem as one involving the cc1 and cc7 MIDI controllers. Quote:

    'One problem here was that the MIDI file contained a cc7 event near the beginning of each track. Upon reaching this event during playback, volume will readjust to this level. Setting the sliders in the Sonar console will *not* overwrite these messages. .. when you were previously setting those sliders, you'd have to do the thing where you adjust it slightly before the notes came in. That's because if you started playback from the beginning, it would reset volume to those cc7 events that were written to the MIDI. .. Since you can't tweak those sliders during mixdown to a file, and since it played over from the beginning, it had no option but to honor those cc7 events in the tracks.'

    Things I have tried:

    Following the normal practice of using GPO in Finale 2006c and advice from the forums I have tried the following:

    (1) Used the GPO 'Notation' Folder in Finale 2006c which assigns cc1 to Channel Volume and cc7 to Modulation as in a 'standard' MIDI file.
    (2) Tried using GPO Folders 1 to 8 which assigns cc1 to Modulation and cc1 to Channel Volume.
    (3) Applied Human Playback and set this to 'Always'.
    (4) Have followed advice to select all then use the apply Human Playback Plugin.

    I have also tried the following from Robert Piechaud, Quote:

    'Anyway. So you are using the “Mod Wheel” version of the organ (=not Velocity based), outside the Notation folder. In that case, setting the name “Flute” for every staff did solve the problem for me. Every Mod-based organ patch plays back correctly, I don’t see why Sonar would not catch those Mod variations. That said, I unchecked the option “Automatic Expression” in HP custom style, to avoid the kitchy effect of decreasing long notes!

    On the other hand, using the Velocity-based (ignoring Mod) organ patches from the Notation folder, it works without the “Flute” trick.... But the pedals do not respond well, because the organ staves being spread out, HP is confused and doesn’t see the whole thing as a single instrument. In that case, it is enough to create an “Organ” braced staff group enclosing the 2 pedals. Also, since you don’t use any notated dynamic, you must turn the “Base Velocity” to 100 up or so in Playback Settings.'


    Following these solutions, it does seem that the file plays back correctly in Finale. However, the problem still remains in Sonar.

    Recently I bought Sonar 5 Producer which cost almost £400, in addition I've only just bought JABB which cost around £170. I've also upgraded my computer with extra memory, and M-Audio card totalling over £400 .. not to mention Finale 2006 upgrade altogether totalling over £1000 of money I didn't really have. I did this because I wanted to set myself up to really get down to serious writing and arranging. Now I'm spending all my time trying to get things to work with no music output and worrying about the financial outlay not paying off.

    I'm more than prepared to accept it's me missing something and to be labelled stupid, I can handle that. As I mentioned earlier, Tom, Robert and Markleford have all been involved, experts in their fields, and still the problem exits.

    It would be a great help in particular if anyone here who works through Finale 2006 and then in Sonar would let me know how they do it and possibly try it with the files I have put up. However, any help, suggestions from anyone would be welcome.

    The different permetations of the files can be found here:

    Thank you everyone.
    Michael
    Patience is a virtue, sensitivity is a gift

  2. #2

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Michael,

    I loaded the first one of the Finale files, the "Normal file using the usual GPO Notation folder", into Finale06, applied the Human Playback plugin from the Plug-ins menu with Auto Expression set to NONE and saved it as MIDI - no editing done in Finale.

    Next I opened the MIDI file in Sonar Home Studio 4, loaded the GPO VST players with the "9. Notation" instruments as they were set up in Finale, added some Ambience (church preset) and exported it as audio - no editing, no mixing except a slight lowering of the master faders to avoid distortion.

    This mp3 is what I got. Sounds good to me. What is the problem?

    This Cakewalk project file is from Sonar HS 4, which means you should be able to open it in Sonar 5.

  3. #3

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Nickie, we pursued almost your same process previously, but then came across the "conflict" of Finale creating volume information as CC#7 versus the "traditional GPO" method of using CC#1.

    To us, it seemed, the obvious thing to do was to get Finale to output CC#1 values instead, but this is apparently contrary to the "Notation" programming instruments. So it seems there are absolutely no options to output a MIDI file from Finale that uses anything but CC#7 for volume. Is this is indeed correct?

    Not being a Finale user I couldn't say for sure, but we figured it would be best to ask and eliminate the problem at the source, rather than fixing it in SONAR (which I can teach him to do, at least).

    If this *is* correct, then to utilize Finale-output MIDI files without further editing, the GPO player must have its Options set to "Use CC#7 for Volume" (or whatnot). At least if Finale is Michael's primary composition environment, then toggling back and forth between modes will not be a problem: he'll just stick it on "enable CC#7" and let it remain that way for his mixdown work!

    If all of this sounds sensible thus far, then the only remaining task seems to teach Michael the art of Console automation in SONAR, and that shouldn't be too hard. We just wanted to make sure it was the correct solution, the "traditional" way of using Finale->SONAR, before making an effort in "repairing a symptom" instead of "fixing the problem".

    As to the problem with the mp3 output, I can't say for sure but I think parts of it were too quiet (or was this as intended?). I think Michael tried to fix the issue via mix Console tweaks but, since they weren't "automated", they were ignored during file mixdown when the controllers reset due to the initial CC#7 data output by Finale in the .mid file.

    Thanks for your confirmation of many of our observations!

    - m
    Free MFX and other plugins: http://www.TenCrazy.com/
    Markleford's music: http://www.markleford.com/music/

  4. #4

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    [QUOTE=Nickie Fønshauge]Sounds good to me. What is the problem? [QUOTE]

    Hello Nickie,

    Thanks for your previous help and for the Sonar file you provided. The problem is still there. Your file ignores the Sonar Console (mixer) settings.

    I loaded your Sonar file and in Track view I just clicked on play. As each track began to play its part I nudged very slightly the volume slider (bottom left) and the volume in most tracks changed instantly. In fact I don't even have to nudge the slider, simply clicking on the slider is enough.

    I then remixed the file to completely different levels and saved it. I reopened the file and played back without any editing. The volume levels were the same as in the original file, ignoring my remix, and I have to click on the volume sliders to get the remix back. The original MIDI file has volume data of its own which overides any mixing or remix in the Console.

    Thanks for trialling the file.
    Michael
    Patience is a virtue, sensitivity is a gift

  5. #5

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Quote Originally Posted by Markleford
    Nickie, we pursued almost your same process previously, but then came across the "conflict" of Finale creating volume information as CC#7 versus the "traditional GPO" method of using CC#1.

    To us, it seemed, the obvious thing to do was to get Finale to output CC#1 values instead, but this is apparently contrary to the "Notation" programming instruments. So it seems there are absolutely no options to output a MIDI file from Finale that uses anything but CC#7 for volume. Is this is indeed correct?

    Not being a Finale user I couldn't say for sure, but we figured it would be best to ask and eliminate the problem at the source, rather than fixing it in SONAR (which I can teach him to do, at least).

    If this *is* correct, then to utilize Finale-output MIDI files without further editing, the GPO player must have its Options set to "Use CC#7 for Volume" (or whatnot). At least if Finale is Michael's primary composition environment, then toggling back and forth between modes will not be a problem: he'll just stick it on "enable CC#7" and let it remain that way for his mixdown work!

    If all of this sounds sensible thus far, then the only remaining task seems to teach Michael the art of Console automation in SONAR, and that shouldn't be too hard. We just wanted to make sure it was the correct solution, the "traditional" way of using Finale->SONAR, before making an effort in "repairing a symptom" instead of "fixing the problem".

    As to the problem with the mp3 output, I can't say for sure but I think parts of it were too quiet (or was this as intended?). I think Michael tried to fix the issue via mix Console tweaks but, since they weren't "automated", they were ignored during file mixdown when the controllers reset due to the initial CC#7 data output by Finale in the .mid file.

    Thanks for your confirmation of many of our observations!

    - m
    Ummm .. errr .. right. Thanks Markleford

    (Quote) So it seems there are absolutely no options to output a MIDI file from Finale that uses anything but CC#7 for volume. Is this is indeed correct? (Unquote)

    I thought that this is exactly what the famed GPO 'Notation' folder in Finale does. In this folder cc1 becomes cc7. If I'm wrong, perhaps Robert or Nickie will correct me.

    If Console automation is the way then I'll learn quickly so let's go for it.
    Michael
    Patience is a virtue, sensitivity is a gift

  6. #6

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Quote Originally Posted by Prince of Music
    Finale will export using CC#1. I'm not at my music computer, but if I remember correctly you have to put the GPO to always in the HP setup when you are writing the file to midi. I'll look at it more in the morning if this isnt the problem.

    Tom
    Thanks Tom. I have already set HP to 'Always' in all the Finale files I put up for trialling.
    Michael
    Patience is a virtue, sensitivity is a gift

  7. #7

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Right .. this seems to be an ongoing universal problem. I did a google for GPO Sonar cc1 and found these which, for me, seem very relevant. (There are loads more.)

    This post on the Northern Sounds Forum explains the problem of GPO/Sonar cc1/cc7 in a different way.

    http://northernsounds.com/forum/arch...p/t-29167.html

    This post on the Cakewalk Forum also regarding GPO cc1/cc7. This quote about Dimension Pro particularly caught my eye (Markleford, does Sonar have this or did it have it at one time?);

    ' if you prefer CC1 for full GPO compatibility, it's just a click to MIDI Learn CC1 to volume.'

    The full thread can be seen here:

    http://forum.cakewalk.com/tm.asp?m=6...page=2&#687787

    Last but not least, I found this on the Garritan site. This plugin by Dan Hristodorescu remaps the controllers in Sonar.

    this can be seen here: http://www.garritan.com/GPO-SonarPage.html

    Are there any potential solutions here, anything to get excited about?
    Michael
    Patience is a virtue, sensitivity is a gift

  8. #8

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Quote Originally Posted by Markleford
    Nickie, we pursued almost your same process previously, but then came across the "conflict" of Finale creating volume information as CC#7 versus the "traditional GPO" method of using CC#1.

    To us, it seemed, the obvious thing to do was to get Finale to output CC#1 values instead, but this is apparently contrary to the "Notation" programming instruments. So it seems there are absolutely no options to output a MIDI file from Finale that uses anything but CC#7 for volume. Is this is indeed correct?
    If you save as MIDI right out of the box, then yes, it is correct. That is why I keep stressing, you have to apply the Human Playback plugin (from the plug-ins menu), before you save as MIDI. Very important!! Saving as MIDI with real-time Human Playback data is buggy - you get CC#7 instead of CC#1. Saving with Human Playback plugin data is not buggy - you get what you expect to get. You would normally use the same settings, as you use in the real-time Human Playback, but not necessarily. It is f.ex. possible to apply the plugin with CC#64 data instead of CC#68.

  9. #9

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    Quote Originally Posted by Nickie Fønshauge
    If you save as MIDI right out of the box, then yes, it is correct. That is why I keep stressing, you have to apply the Human Playback plugin (from the plug-ins menu), before you save as MIDI. Very important!!
    I did try that too Nickie .. but .. I'll go and try it again right now.

    Thanks for your patience.
    Michael
    Patience is a virtue, sensitivity is a gift

  10. #10

    Re: Finale/Sonar Users .. How do you .. Volunteers to test File

    [QUOTE=Michael_uk][QUOTE=Nickie Fønshauge]Sounds good to me. What is the problem?

    Hello Nickie,

    Thanks for your previous help and for the Sonar file you provided. The problem is still there. Your file ignores the Sonar Console (mixer) settings.

    I loaded your Sonar file and in Track view I just clicked on play. As each track began to play its part I nudged very slightly the volume slider (bottom left) and the volume in most tracks changed instantly. In fact I don't even have to nudge the slider, simply clicking on the slider is enough.
    This "problem" is due to your dynamics expressions & mixer settings in Finale. If you change these before saving, Sonar will reflect the changes. Alternatively you can delete the CC#7 data from each track in the Event List. When you are in the Event List, press "V", and in the Event List manager uncheck all but Controller in the first column. This will show nothing but controller data in the track. Do this for each track. CC#7 data is typically (although not necessarily) located at the beginning of the track. Once the CC#7 data is gone, mixer volume will be solely controlled by the sliders.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •