• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Topic: Giga Teleport and Performance Tool

Share/Bookmark
  1. #1

    Question Giga Teleport and Performance Tool

    I already posted this at the FX-Max forums, but traffic there has been a bit light of late, and I'm in a hurry, and there are a lot of experts here.

    I've managed to set up a two PC LAN - one sequencer machine and one Gigamachine - and got Gigateleport working fine (not FX teleport). Now it occurs to me that I haven't a clue how to insert the VSL performance tool into the MIDI chain. The only way I can think of is to have the performance tool on the sequencer machine, route MIDI from Cubase to it, then back to another track in Cubase, whose output is the Gigateleport VST, and from there to the Gigamachine. This seems horrendously convoluted.

    Is there a simpler way that I'm overlooking?

  2. #2

    Re: Giga Teleport and Performance Tool

    Quote Originally Posted by Pingu
    I already posted this at the FX-Max forums, but traffic there has been a bit light of late, and I'm in a hurry, and there are a lot of experts here.

    I've managed to set up a two PC LAN - one sequencer machine and one Gigamachine - and got Gigateleport working fine (not FX teleport). Now it occurs to me that I haven't a clue how to insert the VSL performance tool into the MIDI chain. The only way I can think of is to have the performance tool on the sequencer machine, route MIDI from Cubase to it, then back to another track in Cubase, whose output is the Gigateleport VST, and from there to the Gigamachine. This seems horrendously convoluted.

    Is there a simpler way that I'm overlooking?
    Off the top of my head:

    Performance Tool on slave
    Virtual MIDI cable on slave to route to the PT (VSL MIDI Router)
    Route PT to GS inputs, setting MIDI ports to None on GS.

    I'll check this up later.

    D

  3. #3

    Re: Giga Teleport and Performance Tool

    I thought of that too, but I think the only thing Gigateleport will output to is Gigastudio. I'll try it out though.

  4. #4

    Re: Giga Teleport and Performance Tool

    Daryl is correct, that's how it is done: with the PT on the Giga Computer, Giga midi inputs set to "none", and a virtual midi port on both the sequencer and giga computer.

    After it's all routed, if it the Giga machine doesn't seem to be recieving commands through the chain, as strange as it sounds - rebooting the computers a few times always seemed to fix it for me. Make sure the IP addresses don't change, so if it's a dynamic network make sure to turn the computers on in the same order everytime, just to eliminate misc potential bugginess.

    Once it starts working, it should continue to. I just wanted to add that the first time you try to get everything talking, I've always had issues where it just wouldn't get the signal through to GS. After a few rounds of cleaning my computers and doing fresh installs over almost a couple years, I eventually learned that with a few reboots (sometimes as many as 4-5) it just seemed to work finally, and afterwards it was quite stable. It's just the first round that feels tricky.

    Good luck!

  5. #5

    Re: Giga Teleport and Performance Tool

    Just re-read your second post, Pingu. Giga-Teleport will only route to Gigastudio, you are correct. That's why if you want to use the VSL Performance Tool, you must use another Virtual Midi Port of some sort, such as the free VSL Midi Router (which I haven't used), or MusicLabs Midi-Over-LAN.

    You must install this virtual port on both the sequencer computer and the slave computer, and this will give you additional midi I/O over the network. The PT will see this virtual midi input and offer it as an option, just as your sequencer will see the same virtual midi output and offer it as an option. So any instruments that you want to use the VSL PT with, you must trigger over this midi port, which will feed into the PT, which will feed into GS, and since GS is using the GigaTeleport audio drivers, you will hear the PT instruments digitally along with the rest of your sounds. The other ports/channels bound for GS can be fed just with the GigaTeleport midi outputs.

    So it will help if you try to keep any instruments that require the PT on the same midi port or two.

    On a side note - I really did think that this would no longer be required once GS3 came out, since all the PT features could be built as iMIDI rules. Oh well.

  6. #6

    Re: Giga Teleport and Performance Tool

    Actually you need to sort of "disable" the output in the wrapper to GigaStudio and choose the virtual MIDI driver, as like this.



    Cheers,
    Frankie

    EDIT : edited the screenshot.... my IP was showing and I feel naked!!!
    Dell Precision T3500 (Xeon W3520, 12GB RAM) / Windows 7 x64 / Sonar 8 / VE Pro / WIVI 2.3 / Kontakt 4 / G-Player 1.2

  7. #7

    Re: Giga Teleport and Performance Tool

    Frankie - I never could get the MOL port to show up as an option in GigaTeleport. That's awsome. I stopped using it a while back and got sound cards for the GS comps, but I always planned on going back if I could sometime, once(if) compatibility with Gigapulse was better, since now you can only use 1 instance of it else "pop bang boom!"

    I've never used Maple, maybe that would work better?

  8. #8

    Re: Giga Teleport and Performance Tool

    Quote Originally Posted by MikeGraybill
    I've never used Maple, maybe that would work better?
    That's what I heard of too since day 1. So I can't really compare since I never used the VSL virtual drivers. But at least it works perfectly smooth for my Giga machines (host and server).

    MOL might be easier to use than GT from what I heard of too. I do have GSIF soundcards on all of my computers... I bought GT instead of MOL just for the sake it was cheaper at the time I bought it, hehe!

    Cheers,
    Frankie
    Dell Precision T3500 (Xeon W3520, 12GB RAM) / Windows 7 x64 / Sonar 8 / VE Pro / WIVI 2.3 / Kontakt 4 / G-Player 1.2

  9. #9

    Re: Giga Teleport and Performance Tool

    Quote Originally Posted by FrozeN
    Actually you need to sort of "disable" the output in the wrapper to GigaStudio and choose the virtual MIDI driver, as like this.



    Cheers,
    Frankie

    EDIT : edited the screenshot.... my IP was showing and I feel naked!!!
    Sorry, I forgot this bit, but anyway I've now checked and I use VSL Router on Slave "in" to PT and GIGAOUT PORT 1 out of PT, GS in ports set to none.

    D

  10. #10

    Re: Giga Teleport and Performance Tool

    Thanks everyone. I'm at work at the moment, but I'll try this out tonight.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •