• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Topic: J&BB and CPU problems

Share/Bookmark
  1. #1

    J&BB and CPU problems

    Hi folks,

    I just have my J&BB library since a couple of hours, and it sounds so great. but I have a problem with my CPU. I've loaded a full big band and he processor is in the red in the tutti. I've downloaded the upgrade but even the problem is less important, I still have theses clics while playing my music.
    Any advice is welcome.
    regards
    L
    On mac G 5 2x2,5 Ghz, 2,5 Go RAM

  2. #2

    Re: J&BB and CPU problems

    Have you tried the "Lite" choices in the update? They take significantly less processor power. You could try substituting lite instruments for the less prominent parts and see if you can lower the CPU demands enough to fix the audio glitches. Also, look to the most demanding instruments for polyphony: Piano and cymbals are good candidates. Try lowering the polyphony assignment for these instruments to see if you can reduce demands without audible side effects. Make sure that what you are experiencing is actually CPU overload and not mixer gain-stage overload by dropping back the overall level of the mix. Experiment with soundcard buffer sizes if you have access to them. At least those are some of the things I would try.

    Tom

  3. #3

    Re: J&BB and CPU problems

    Hi Tom,
    Thanks for these advices I'll try what you're suggesting. I'm sure that there's not a problem with the mix, because I' ve check the performance of my processor (with DP at the "performance" menu) and it seems that it's the problem.
    I'll try to boot the lite verions of the instruments, and, effectively, I have a big piano part. I'll perhaps make a sounbite of the piano part.
    thanks again for your help.
    Laurent
    On mac G 5 2x2,5 Ghz, 2,5 Go RAM

  4. #4
    Senior Member Tom Crowning's Avatar
    Join Date
    Sep 2005
    Location
    On the other side of the big pond
    Posts
    226

    Re: J&BB and CPU problems

    Quote Originally Posted by bmtl
    I'll try to boot the lite verions of the instruments, and, effectively, I have a big piano part. I'll perhaps make a sounbite of the piano part.
    thanks again for your help.
    Laurent
    I use the lite versions of the (GPO-) pianos all the time because they load
    much faster.
    I only load the full version for the final rendering to disk.

  5. #5

    Re: J&BB and CPU problems

    open up your latency on your sound card.
    Houston Haynes - Titan Line Music

  6. #6

    Re: J&BB and CPU problems

    Quote Originally Posted by Houston Haynes
    open up your latency on your sound card.
    That's what I did and it works; even the processor performance is highly used, I don't have the problems I had before.
    And I don't use the J&BB piano, but the lite piano of GPO witch sounds better to me and use less CPU ressource than the other.
    regards
    L
    On mac G 5 2x2,5 Ghz, 2,5 Go RAM

  7. #7
    New Member
    Join Date
    Dec 2005
    Location
    Massachusettes
    Posts
    12

    Re: J&BB and CPU problems

    Quote Originally Posted by Houston Haynes
    open up your latency on your sound card.
    Can anyone direct me how to do that on a Mac G4 laptop. I know how to lower the CPU demands in the Ambience window but not how to "open up latency on the sound card". I'm a bit new to the sampling world--help is appreciated.
    jazztao

  8. #8

    Re: J&BB and CPU problems

    Quote Originally Posted by jazztao
    Can anyone direct me how to do that on a Mac G4 laptop. I know how to lower the CPU demands in the Ambience window but not how to "open up latency on the sound card". I'm a bit new to the sampling world--help is appreciated.
    jazztao
    Garritan Jazz -> Preferences - > SoundCard -> Output Latency

  9. #9
    New Member
    Join Date
    Dec 2005
    Location
    Massachusettes
    Posts
    12

    Re: J&BB and CPU problems

    Quote Originally Posted by Thad
    Garritan Jazz -> Preferences - > SoundCard -> Output Latency
    Thad
    Thanks for this --I tried lowering moving the latency to various levels and it unfortunately didn't help--the track still had static while playing back--my CPU must be just too insuficient.
    Thanks anyway--I've been planning to upgrade.
    best
    Jazztao

  10. #10

    Re: J&BB and CPU problems

    Laurent,
    Make sure your buffer setting in DP is set to at least 1024. You can check this by going to...

    Setup/configure audio system/configure hardware driver, then buffer size.
    The lower the number, the less time delay there will be for playing parts on a keyboard, a higher setting provides much more time for the computer's CPU to get things in order, and yields way better sound performance (less clicking & popping). This buffer setting in DP is something that you will be changing quite often.

    A very simple fix for a system under extreme stress, and even when it's not, is to record the individual instruments to separate audio tracks in DP, and then mix the sound in the mixing board "shift M". Mute everything except the piano and record it to a stereo audio track, once it is recorded, then mute the midi track and go on to the next few instruments. With the audio assignment stereo pair in the Kontakt player, you can set up many stereo audio tracks and record many at the same time, it just depends on the resources of your computer. Just make sure that the audio tracks' input matches the "assigned output" of the instrument in the Kontakt player. If you still encounter lots of bad sound and chopped up notes, you may need to delete the the bigger instruments in the Kontakt player as Tom has suggested... like the piano, and any other instruments that have lots of notes and/or long decay, such as piano, timpani and cymbals. Back in the tracks window "Shift T", use the "comments" section to keep track of the actual instrument you used for that track, this way, in case you decide to change something in the mid track after you recorded the audio, you can load the correct instrument and re-record that portion into the same audio track, there is no need to re-record the whole track.

    So, to do this....

    In the Kontakt player, the stereo output of each instrument is assigned by clicking on the 1/2, then a dropdown box appears. Set the piano to 3/4 since you will likely be using bus 1/2 for reverb.

    Go to "Project" and select "ADD TRACK" then select "stereo audio track" or better yet, hit Shift T for the tracks window, and highlight the piano midi track name, now hit shift/command S. This is a shortcut to adding a stereo audio track, and highlighting the name of the track in this "tracks window", places the new audio track directly under the piano midi track so you don't have to move it later. I always keep my audio track directly beneath the midi track. Now, title it pno, and set the input for this track to Garritan Jazz... stereo pair 3/4, also, make sure that this stereo audio tracks' output is set to your output device whatever it is. Don't be lazy, color code all of your tracks so you can immediately recognize them. If you adopt a certain strategy for color coding, you can use this for all future projects, and you will not have to learn all over again for every new project.
    I use common sense when it comes to instruments and their color.

    flute, pink
    clarinet, light blue
    tuba, brown
    violins, red
    2nd vlns, orange
    viola, yellow
    cellos, green
    bass, dark blue
    bassoon, purple

    If a sound is bright and shrill, use a bright shrill color, if it is dark sounding use a dark color, you get the idea

    By recording all of these instruments to audio, you can eliminate the need for the computer to process the sound of all these instruments simultaneously. If you have not checked it out, read the tutorial on the Audio Mixing Tutorial I did on Garritan's website, it is very helpful for those who are not familiar with audio mixing. It's fun!

    Try it you'll like it!

    dpDan

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •