• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Topic: Can't get low latency in Kontakt 2 on a PC

Share/Bookmark
  1. #1

    Can't get low latency in Kontakt 2 on a PC

    I'm normally a Mac guy, so maybe I've just overlooked something obvious to a PC guy. My problem is if I set the latency in Kontakt 2 below about 15ms, the notes get very distorted and performance is erratic. This happens for EWQLSO patches or even Kontakt factory patches.

    My rig is a 3.2Ghz P4 on an Intel board with Western Digital WDC-WD2500JS-00MHHB0 250 gig hard drives that are supposedly (according to the guy who built my computer) good for streaming audio. I have 2 gig of RAM and I'm running Windows XP Home Edition Version 5.1 Service Pack 2.

    Anything jump out at you?

    On an unrelated note, where would I get software to format hard drives for PCs? I bought a bunch of firewire drives, but they're partitioned and I want to reformat them without the partitions. With Macs, there's a built in disk utility, but I can't find the equivalent on Windows. Is it there or should I buy a utility? Thanks!

    - Mike Greene

  2. #2

    Re: Can't get low latency in Kontakt 2 on a PC

    What audio interface do you have? To get the best performance from most interfaces or soundcards you will need to select the ASIO drivers in Kontakt's Audio Preferences. Usually there are several ASIO drivers in the list that will appear. There will be 'ASIO MME' and 'ASIO Direct X' which are generic drivers with poor performance. If your interface has its own ASIO drivers they will probably appear with the name of the manufacturer or the card; for instance mine appear as 'ASIO DELTA.'

    I also had the problem of massive latency, or pops and crackles, until I realised I had accidentally selected the ASIO Direct X drivers. Since switching to my card's dedicated drivers I've managed incredible performance.

  3. #3

    Re: Can't get low latency in Kontakt 2 on a PC

    Thanks for the input. Sounds like you may be onto something.

    I'm using an Echo Layla 3G. Under my Kontakt (Kompakt) settings, I have it set for DirectSound (as opposed to ASIO or Multimedia.) Is that what you mean, or is there a separate place where I select a driver?

    - Mike Greene

  4. #4

    Re: Can't get low latency in Kontakt 2 on a PC

    I can't really remember where you select drivers in Kontakt (I'll look in the morning if you haven't found it), but there ought to be one labelled 'ASIO Echo' or 'ASIO Layla' or something similar when you find the drop-down list.

  5. #5

    Re: Can't get low latency in Kontakt 2 on a PC

    That would be great if you could check where that menu is. I've clicked all over this dang program and all is see is the File>>Setup>>Soundcard page. Thanks!

    - Mike Greene

  6. #6

    Re: Can't get low latency in Kontakt 2 on a PC

    File - Settings - Audio/Midi Setup...that's from the stand alone version...This is off the top of my head, I don't have Kontakt in front of me, but you may need to right click at the top of the Kontakt window...I'll check it when I get home shortly although it sounds like you have already found it.
    Edward W. Trevino
    Dandlewood Productions
    www.dandlewood.com

  7. #7

    Re: Can't get low latency in Kontakt 2 on a PC

    Hi Mike, do you have firewall and anti-virus running on this machine? Is it connected to the internet? This might be hampering your performance.

    In regard to formatting etc, go to the start menu, find "My Computer" and right-click on it. Go to "Manage"

    Then go "Disk Management" - in there you can format partitions (not the system drive), resize disk partitions etc.

    -Scott.
    ---------------------------
    - SCA - Sound Studios -
    www.sca-soundstudios.com
    ---------------------------

  8. #8

    Re: Can't get low latency in Kontakt 2 on a PC

    Quote Originally Posted by Mike Greene
    I'm using an Echo Layla 3G. Under my Kontakt (Kompakt) settings, I have it set for DirectSound (as opposed to ASIO or Multimedia.) Is that what you mean?
    That's the place. After having set "Interface" to ASIO instead of DirectSound,
    you'll be able to select the low latency driver.

  9. #9

    Re: Can't get low latency in Kontakt 2 on a PC

    I went to File>>SetUp>>SoundCard and changed the interface to ASIO. Then, under Output Device, my only choice is "ASIO Echo WDM." Next to it is a button for ASIO configuration.

    On the ASIO Configuration screen that pops up, all I can select are buffer sizes (which affect latency) and two switches for "Enable ASIO 2.0 Direct Monitoring" and "Short Channel Names."

    This all seems good, except I can't get any sound now. The audio meters in Kontakt dance around as they should, but there is no sound and when I call up the Echo mixer, the meters show no action.

    If I switch back to DirectSound, I get sound again. Weird. Any ideas? Or thoughts on where I should read up?

    - Mike Greene

  10. #10
    Senior Member Bruce A. Richardson's Avatar
    Join Date
    Sep 1999
    Location
    Dallas, Texas
    Posts
    5,755

    Re: Can't get low latency in Kontakt 2 on a PC

    Quote Originally Posted by Mike Greene
    I went to File>>SetUp>>SoundCard and changed the interface to ASIO. Then, under Output Device, my only choice is "ASIO Echo WDM." Next to it is a button for ASIO configuration.

    On the ASIO Configuration screen that pops up, all I can select are buffer sizes (which affect latency) and two switches for "Enable ASIO 2.0 Direct Monitoring" and "Short Channel Names."

    This all seems good, except I can't get any sound now. The audio meters in Kontakt dance around as they should, but there is no sound and when I call up the Echo mixer, the meters show no action.

    If I switch back to DirectSound, I get sound again. Weird. Any ideas? Or thoughts on where I should read up?

    - Mike Greene
    That's not normal. Have you looked in the Echo driver interface itself for meter movement? You might have your output mutes set up unconventionally. It's not the easiest mixer interface by a long shot. But you should be seeing meter movement.

    You might need to configure the i/o in MIDI/Audio setup within Kontakt, and enable the specific mixer outputs once you've switched to the ASIO mode. The DirectSound leaves this decision up to your Windows OS settings. However, the ASIO mode makes it up to the application which i/o is enabled per routing option. So be sure to check that out. I'm not sitting in front of Kontakt right now, but I'm pretty certain it's on the standard dropdown menu under MIDI/Audio setup.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •