• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Topic: GPO percussive instruments in Sibelius sound bad

Share/Bookmark
  1. #1

    GPO percussive instruments in Sibelius sound bad

    This title has a purpose of catching Forum's attention in order to get some usable responses to a bizarre problem with playing back some percussive and quasi-percussive instruments from GPO in Sibelius. If you ever tried to play fast passages (f.e. quarters in 220) of piano or snare drum you will find that the playback is uneven, i.e. like played by somebody who did not practice long time and now his fingers "run" and some notes follow the others faster that they normally should if played with a proper precission. To spare your time I would add that I tried tricks with life velocity, performance (expressivo and rubato) I even played a bit with lengths of notes to check whether they run into each other making little jams in passages. Nothing helped, so now is the time to seek a council from Forum.
    As usual any help will be greatly appreciated
    Witold

  2. #2

    Re: GPO percussive instruments in Sibelius sound bad

    This happens to me when I'm running a full orchestral tutti with GPO studio. Probably a CPU problem in my case (I have a P4 1.8 GHz which is at the bottom of recomendations).
    How are your cpu levels?

    -Chris

  3. #3

    Re: GPO percussive instruments in Sibelius sound bad

    Witold,
    Try reducing the polyphony of the problematic percussives.

    Below the "CPU Usage" display for the instrument there are two small boxes:

    The one to the left is the midi channel.
    The next one to the right is the polyphony. If you position the mouse over the left-hand digit (if you see "0/32", position it over the "32") and drag down. This will lower the number.

    Lower it substantially to start, say to 8, for the snare, and see if the passage plays correctly.

    The piano polyphony is set quite high to provide for the sustain pedal and legatos. If your piano passages are not complex, with minimal sustain pedal and legato, you can lower the polyphony quite a bit without affecting the sound.
    Bill

  4. #4

    Re: GPO percussive instruments in Sibelius sound bad

    Quote Originally Posted by billp
    Witold,
    Try reducing the polyphony of the problematic percussives.

    Below the "CPU Usage" display for the instrument there are two small boxes:

    The one to the left is the midi channel.
    The next one to the right is the polyphony. If you position the mouse over the left-hand digit (if you see "0/32", position it over the "32") and drag down. This will lower the number.

    Lower it substantially to start, say to 8, for the snare, and see if the passage plays correctly.

    The piano polyphony is set quite high to provide for the sustain pedal and legatos. If your piano passages are not complex, with minimal sustain pedal and legato, you can lower the polyphony quite a bit without affecting the sound.
    Thanks all of you for your suggestions as they ALL led to discovering the real source of the problem. Whenever you experince such unevenness as I described above go FIRST and STRAIGHT to GPO Studio and check the latency of your audio driver. In case of ASIO drivers the latency is adjustable so if your CPU permits cut it down as much as you can. Then if this does not help you can start blaming your notation program, but not before. As my CPU allowed me easily doing it I cut the latency to 10ms and immediately regained the precision.
    Again thanks all of you for nudging my mind in the good direction.
    Witold

  5. #5

    Re: GPO percussive instruments in Sibelius sound bad

    I thought the polyphony was just a ceiling and didn't affect the CPU unless the instrument was actually using that polyphony? Like, you can put the piano all the way up to 256-note and have it only use 24 of it and the CPU will still only be using that 24 and not worrying about the rest.
    Isn't that how it works?

    -Chris

  6. #6

    Re: GPO percussive instruments in Sibelius sound bad

    Quote Originally Posted by cptexas
    Isn't that how it works?
    Yes, that's right, Chris.

    But if you have the polyphony set on say, 32, and do an intense timpani roll, the overlapping notes (tails, etc) may require that subsequent notes take more bites from the polyphony max. You'll see the polyphony count surge in these circumstances.

    As the polyphony count (in use, not the limit) goes up, it has basically the same effect as playing several instruments simultaneously. If your latency is set too low, you'll top out and get dropouts.

    So as an alternative to setting your latency higher, or a way to decrease the instantaneous load on your CPU, is to reduce the polyphony of the highly polyphonic instruments (piano, timpani, etc) so that the max number of samples that can be sounding at any one time for that single instrument is limited...to the max polyphony setting. Of course if you go too low, you lose some of the natural legato qualities that you get from the note overlapping.

    Once the polyphony limit is reached, the player will drop an earlier note that is still playing (note stealing) and play the newly struck one. You can get reasonable timpani rolls with a polyphony max substantially lower than 32 (or whatever the default max is), and without as much risk of having transient passages where you hit a latency bottleneck.

    You can see the effect of polyphony on the CPU (due to latency) by setting your latency low and pressing down 2 or 3 octaves of keys simultaneously on the piano. Watch the polyphony count and your cpu consumption jump up.

    Then, reduce the polyphony maximum to about 8 or so and do the same thing. You'll see the cpu utilization drop substantially. Of course not all the notes will sound either.

    For a demo of note stealing, set the polyphony of the piano to 3, play and hold a 3-note chord with your left hand, and then play another 3-note chord with your right hand. When you lift your right hand, the original left-hand chord will no longer be sounding.
    Bill

  7. #7

    Re: GPO percussive instruments in Sibelius sound bad

    No, the polyphony is evidently not simply a ceiling for number of voices. It seems to govern overhang of resonance duration as well. (Update: see billp above for the technical description posted while I was writing this --he's an authority.)

    I was having exactly the same problem with percussion in a battle piece where timpani and bass are pounding constantly, and also with my piccolo playing unintended "notes inegales" in the same piece. See my recent post on "Imprecise percussion" in Support & Technical. A new soundcard helped some (EMU 1212M vs Soundblaster), but it still didn't sound like it was supposed to. Not till I read these posts could I fix it.

    First I screwed down the latency from 50 to 10, which finally sounded super except that some new crackles and pops started to occur. The CPU (P4 2.8 GHz) got up close to 100% on the Usage meter at the end of the piece where the timpani and bass drum are rolling together and static noise built up at the climax. At latency 20 it's still a problem. So I screwed down the polyphony in the percussion to just 1 or 2 and that does help. I still hear more scratchiness than I like but it's tolerable. Thanks to Bill and others for tips.

  8. #8

    Re: GPO percussive instruments in Sibelius sound bad

    Looking at my wav file in Audacity after I record the piece in question, I see that some of my waveforms are clipped. Are these the cracks I hear? How do I keep within the recording parameters? I didn't think I had the intensity turned up high.

  9. #9

    Re: GPO percussive instruments in Sibelius sound bad

    General comment:

    Unless you are capturing your midi tracks by recording sound with sound in real time, you should not be lowering your latency, but increasing it. I routinely set mine at 20ms (buffer 1024 @44.1) or even 40ms (2048) when mixing and using effects like convolution reverbs. You are working against yourself if you try to work with low latencies when you are simply scoring and not playing real time. By increasing the latency, you can avoid having to mess with the polyphony at all.

    Of course, achieving any latency value is entirely dependent on your CPU, soundcard, and drivers.
    Bill

  10. #10

    Re: GPO percussive instruments in Sibelius sound bad

    I am playing back and recording from Sibelius, no realtime instruments.

    I increased latency to 60, and the timpanist sounds like he had a couple glasses of wine. Back to 20, he's on coffee.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •