• Register
  • Help
Results 1 to 3 of 3

Topic: Loading instruments in Logic XP7

Share/Bookmark
  1. #1

    Loading instruments in Logic XP7

    I have never been able to get this to work. I read the tutorial by Kevin Rix, but the only instrument I can successfully play is in the first position in the Kontakt Player, so MIDI channel 1. I loaded Steinway Piano and it plays beautifully. The MIDI channel in Logic Express is also set to Channel 1. Fine.

    In the Kontakt Player, I clicked on the second of the eight slots and loaded Violin 1 and designated MIDI Channel 2 for that instrument.

    When I go back to the Arrange window in Logic Express and click on the second Instrument track that I want to play Violin 1 on, I change the MIDI channel in Logic to 2. When I then play what should be a Violin 1 sample, I hear the piano and then see MIDI data flashing on both channels in Logic.

    Any ideas? It's as if no matter how many virtual instrument tracks I make in Logic, it will only read MIDI channel 1 from the Kontakt Player. Growl.

    Thanks,
    Sean...

  2. #2

    Re: Loading instruments in Logic XP7

    I just load one instrument per player, takes longer, but no hassle.

    Quote Originally Posted by seanmcd
    I have never been able to get this to work. I read the tutorial by Kevin Rix, but the only instrument I can successfully play is in the first position in the Kontakt Player, so MIDI channel 1. I loaded Steinway Piano and it plays beautifully. The MIDI channel in Logic Express is also set to Channel 1. Fine.

    In the Kontakt Player, I clicked on the second of the eight slots and loaded Violin 1 and designated MIDI Channel 2 for that instrument.

    When I go back to the Arrange window in Logic Express and click on the second Instrument track that I want to play Violin 1 on, I change the MIDI channel in Logic to 2. When I then play what should be a Violin 1 sample, I hear the piano and then see MIDI data flashing on both channels in Logic.

    Any ideas? It's as if no matter how many virtual instrument tracks I make in Logic, it will only read MIDI channel 1 from the Kontakt Player. Growl.

    Thanks,
    Sean...

  3. #3

    Re: Loading instruments in Logic XP7

    You might want to do a search on this forum using Logic as a key word. You might just find the answer to your problem. I will be getting Logic in a week or so (I usually use Digital Performer) and if you haven’t found the answer to your problem by then, I’ll see if I can help you further.

    Best of luck,

    Karl

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •