• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Topic: Who ever said turn off Virtual Memory??

Share/Bookmark
  1. #1

    Who ever said turn off Virtual Memory??

    Before I upgraded my system I was sequencing Tchaikovsky using EWQLSO GOLD with 1 GB of ram. Virtual Memory was turned off and my system could only handle 3 instances of Kompakt (8 channels x 3 ) before crashing. Only after I set the maximum paging file was I able to achieve 5 instances (40 channels) on 1 GB of RAM. Since then, I've upgraded to 3GB of ram so I don't have nothing to worry about. But just to let those who may have some Ram problems that Virtual Memory can help.

    Always, here's a snippet of Tchaikovsky using around 40 channels (8 x 5). There is not much bandwidth on this site so if it has reached it's limit, check back later.

    http://ca.geocities.com/rrosadiuk487...chaikovsky.mp3

  2. #2

    Re: Who ever said turn off Virtual Memory??

    Turning virtual memory off was a trick used in the times when computers couldn´t handle pagefiles very well. A long time ago, you could actually improve performance by turning it off, but today things changed. I am quite shocked to see that some people still recommend this procedure today... old habits die hard.

  3. #3

    Re: Who ever said turn off Virtual Memory??

    I've read conflicting recommendations on this.

    I have a P4 with 2 Gigs Ram.
    Currently my C drive (operating system and programs) is set at 2046 minimum and 4092 maximum)
    On my E drive (Giga samples) the paging file is turned off.

    What would be the best settings in your opinion

    Mal

  4. #4
    New Member
    Join Date
    Apr 2005
    Location
    Sunny, Fun, SoCal
    Posts
    4

    Re: Who ever said turn off Virtual Memory??

    Yes please if anyone knows about this I'm really screwed right now...I'm using 1 GB RAM with a minimum of 1486 and max of 3000 page file and I can't even load one instance of Kontakt or EWQL Gold without tons of glitches and dropouts...

    When I load my project into cubase (22.035) when it gets to 75 percent it says that "physical memory is too low! proceeding can cause problems...and so it does

    the thing is that my computers CPU doesn't even go above 15-20 percent but the cpu meter on the EWQL kompakt player maxes out...I've tried lowering the buffer and all the different settings in cubase to no avail...using an Echo Mia Midi card...

    I have windows XP on drive C, cubase on drive F of same HD, and the EWQL gold samples and audio partitions are on another HD so there should be no problem right?

    Should I be doing the "DFD" thing?

    Any help for this comp moron would be greatly appreciated!

  5. #5

    Re: Who ever said turn off Virtual Memory??

    Why did you not install Cubase on the C drive? Certainly you'd want your audio projects residing on another hard drive and your samples on a third hard drive, but there's no reason to install Cubase anywhere other than the system partition, although installing it on another partition on the same HD isn't necessarily bad.

    You should be using DFD in Kontakt. It will save RAM and most of the samples will stream from disk as needed. If you don't use it, Kontakt must load the entire sample into RAM and you will max out very quickly with large sample sets.

    Oh, and typically it is recommended to set the minimum and maximum sizes for page files to be the same value on a DAW - usually something like twice the RAM size, although since I have 2GB I set the page file to 2048mb min/2048mb max, since I doubt Windows would ever use that much page file in a normal DAW scenario.

    fizbin

  6. #6
    New Member
    Join Date
    Apr 2005
    Location
    Sunny, Fun, SoCal
    Posts
    4

    Re: Who ever said turn off Virtual Memory??

    Quote Originally Posted by fizbin
    Why did you not install Cubase on the C drive? Certainly you'd want your audio projects residing on another hard drive and your samples on a third hard drive, but there's no reason to install Cubase anywhere other than the system partition, although installing it on another partition on the same HD isn't necessarily bad.

    You should be using DFD in Kontakt. It will save RAM and most of the samples will stream from disk as needed. If you don't use it, Kontakt must load the entire sample into RAM and you will max out very quickly with large sample sets.

    Oh, and typically it is recommended to set the minimum and maximum sizes for page files to be the same value on a DAW - usually something like twice the RAM size, although since I have 2GB I set the page file to 2048mb min/2048mb max, since I doubt Windows would ever use that much page file in a normal DAW scenario.

    fizbin
    Thanks for replying, I didn't install cubase on the main C drive because it was getting full with stuff so I opted to put it on F drive...then I have another internal 120 GB HD with the EWQL and library on one partition, and then I have a 25 GB partition for the audio files...doing this because of what I've read...

    I've tried all types of adjustments of the page file and did it like you said, min and max the same, but nothing makes any difference...BTW the page file is on the C drive, should I try setting one on one of the other drives?

    I just tried installing the DFD and turned it on in EWQL gold but it didn't seem to make any difference...between 75 and 85 percent of the project with 1 instance running it says physical memory is wasted already...f***!

    Also I noticed the little "light" in EWQL gold is not illuminated so I don't even know if it's really on yet...

    I wish I knew more about this ~~~~, it seems like I make one minute of music and again I'm troubleshooting and searching around the web for the next week...

    thanks again and let me know what you think if you have the time

  7. #7

    Re: Who ever said turn off Virtual Memory??

    Quote Originally Posted by fizbin
    Oh, and typically it is recommended to set the minimum and maximum sizes for page files to be the same value on a DAW - usually something like twice the RAM size, although since I have 2GB I set the page file to 2048mb min/2048mb max, since I doubt Windows would ever use that much page file in a normal DAW scenario.

    fizbin
    Thanks for the tip.
    Would that setting be for both the "C" drive (XP and GS3) and the drive that the samples are on?

  8. #8

    Re: Who ever said turn off Virtual Memory??

    If you're using DFD streaming (which you should) and virtual memory is enabled, Kompakt buffers some of the data to paging file. This will definitely slow down performance since the sampler have to read samples twice from the disk. When virtual memory is disabled, Kompakt buffers only to RAM and the performance should obviously be smoother this way. With low amount of RAM you may gain some benefit with VM on, at least you get more instruments loaded.

    When using DFD streaming with disabled virtual memory, you should carefully monitor your memory status from Windows task manager. Kompakt doesn't "fill" the buffers instantly when instruments are loaded. For example, when you load three instances, task manager may imply that only something like 500 MB is used. After half an hour when played around with all of the instruments, the memory status may indicate 1 GB used memory.

    It depends on the DFD settings, how many instruments you can load and how much RAM is used to each instrument's buffer. Smaller buffers, more instruments and vice versa. Larger buffers offer better playback so you shouldn't set up too small buffers for such a big instruments.

    Actually the default DFD settings works quite well in most of the cases. You just have to change the maximum voices to 248 (this means within one instance), so you don't run out of polyphony. I have 2 GB RAM in my computers (VM off) and with these DFD settings I can load five full instances per machine and the performance is very smooth.

    Did you try to make a new project after changing settings. At least try shutting off all the EWQLSO instances within an existing project and then manually reload all the instruments again. Believe or not this has solved some problems too.

    - Mikko

  9. #9

    Re: Who ever said turn off Virtual Memory??

    Unfortunately people here are still spreading mis information about virtual memory (page file) because they don't know how it works internally.

    I will try to sum it up briefly:

    Samplers are very memory hungry so it's easy to use up all the available physical RAM.

    The problem in a sampler is that it needs to provide low latency access to those samples in RAM otherwise you will experience glitches clicks and delays.

    When the operating starts running out of memory it has to make decisions how to manage this critical situation.

    Here the page file comes into help. Basically the system tries to swap out to the page file some data in RAM that has not been used for some time (least recently used).

    Most operating systems provide functions to lock memory areas in physical RAM.
    For example a sampler might ask the OS to not swap out certain areas of memory where the samples reside.
    This works well but if you try to lock down too much memory in physical RAM then the operating system will try to swap out system background processes to the page file and this could cause grinding the machine to a halt.

    So having a page file does indeed help to load/run more applications/data than would fit in physical RAM, but if the sampler wants to be sure that the samples are not swapped out to the page file it HAS to lock them down in memory and in substance the page file will be of only little help.

    The only way to go to have smooth playback is avoiding to load too much samples in RAM. If you leave a 10-20% of headroom (assuming the OS can allocate all the memory) then you will be fine.
    If you want to go over that limit then expect troubles, regardless if the page file is enabled or not.

    PS: windows memory management sucks a bit (eg you cannot allocate all the physical memory efficiently) then this adds even more troubles in addition to the things described above.

    cheers,
    Benno
    http://www.linuxsampler.org

  10. #10

    Re: Who ever said turn off Virtual Memory??

    It was a while ago but of what I can remember, this was the setup I had. I had paging file turned off and I could only open 3 instances of Kompakt. I of course needed more channels so I decided to max my virtual memory and it worked! It gave me 2 more instances (40 channels). I can't remember what the maximum limit was but it was set to something like this:

    C: 4096 Initial - 4096 Maximum (O/S)
    D: 4096 Initial - 4096 Maximum (KOmpakt)
    E: 4096 Initial - 4096 Maximum (Samples)

    It worked for me so it doesn't matter what the theory tells you to do.

    Oh yeah, what also helped was to partition my one 160GB HD 3 times!

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •