• Register
  • Help
Results 1 to 7 of 7

Topic: HOW TO DEFEAT VEL RESPONSE?

Share/Bookmark
  1. #1

    HOW TO DEFEAT VEL RESPONSE?

    I have set up a distributed wave instrument, all samples on keygroup 1 for self-switching, and note-off overide in i-midi. Now I want to stop GS3 responding to velocity data, so I can just use the keyboard as a switching device. I need help, can't find anything in the instrument editor, or elsewhere. Any advice most appreciated - p.s. I need a solution in about 16 hours. Thanks.

  2. #2

    Re: HOW TO DEFEAT VEL RESPONSE?

    As a temporary solution, if nothing else - can you set your keyboard to produce a constant velocity? Or some filter in the sequencer or data stream that could do this before it reached Giga?

    There probably (almost certainly) is a way to do this in the Giga editor, but I am not at my Giga box right now...
    Dasher
    -------
    It's all about the music - really. I keep telling myself that...

  3. #3

    Re: HOW TO DEFEAT VEL RESPONSE?

    I did think of doing that, but I don't think I can do it for midi out from the keyboard (without a sequencer downstream). I know for organ, harpsichord etc. the [.gig] instruments are designed with no velocity response - but how that is done, I have not been able to determine. I have save my distributed wave instrument as a <.gig> file.

    Another funny thing (unexplained) is that with an EPS 16+ sending midi data, or my Korg is40, the i-midi filtering of note-off data works fine, but with my old Roland MKB-1000 and my new M-AUDIO Keystation 88, when I let the key go, the sample playback stops. This is weird, but there must be reason.

    Seems like such a simple, basic thing. Maybe I am even more simple, and basic.

  4. #4

    Re: HOW TO DEFEAT VEL RESPONSE?

    Open your gig in the Editor and then:

    - Hit the 'Select Lock' buttons until everything is orange + selected.
    - Select the 'Response' section of the Edit Parameters window, bottom.
    - Set 'Velocity Curve' to Linear and 'Velocity Curve range' to Low.
    - Save and test

    HTH.

  5. #5

    Re: HOW TO DEFEAT VEL RESPONSE?

    - Hit the 'Select Lock' buttons until everything is orange + selected.
    - Select the 'Response' section of the Edit Parameters window, bottom.
    - Set 'Velocity Curve' to Linear and 'Velocity Curve range' to Low.
    - Save and test
    Careful ... check before following this advice. I believe the High linear setting might be closer to what you want, with an offset. But there ought to be a better way ... and I could be wrong and Ash right about the low/high curves.

  6. #6

    Re: HOW TO DEFEAT VEL RESPONSE?

    Quote Originally Posted by gugliel
    I believe the High linear setting might be closer to what you want, with an offset.
    Quite possibly - what i suggested is a just a simple and quick way to defeat vel response so that GS always responds as if vel=127. If our original poster requires a wider window of velocity response, e.g. within 10-20, then as you suggest an offset + a different curve might well be the solution required.

    (The one iMIDI rule per instrument limit is restricting here, as without it another rule could be added to compress the incoming velocity ranges without having to mess around with response curves...)

  7. #7

    Re: HOW TO DEFEAT VEL RESPONSE?

    Thanks guys, that worked (Ash's suggestion). Yes, all I wanted was to get vel = 127, no matter what. I'll experiment with other refinements now I know a bit more about this. AND you gave me an answer IN TIME, I am very grateful.

    Cheers.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •