• Register
  • Help
Results 1 to 2 of 2

Topic: UATA66 with UATA33

  1. #1

    UATA66 with UATA33

    Anybody experiencing the same problem with Seagate drive and DMA?
    I have bought a Seagate 320423A (UATA66) drive for Gigasampler. It sits on my Secondary Master (Fujitsu UATA33 is on the Primary). I connected the drive as I bought it and it worked O.K. as long as I did not switch the DMA on in Control Panel. I contacted Seagate and they suggested the drive has to be switched to UATA33 mode. Since my motherboard supports only UATA33, I used the UATA66 utility suplied by Seagate to toggle the drive to the slower mode. The first time I started Windows98 afterwards the disc was recognised and also the DMA box was checked by Winows itself. However since the next start of the computer is the situation the same as before and no changing of MODES helps anymore.
    The drive is recognised by W98 as Generic disk type 80 with DMA turned off. It works without problems but is of course slow. When I click into the field DMA (in the Control Panel) I get the Unsupported
    Hardware Allert (Contact your Hardware Vendor etc.). I can go on, but after
    restart, the drive has big problems. If I want, for instance, to copy a
    file from my Fujitsu HD onto the Seagate, the disc activity happens to be
    about 4 times pro second (the HD LED is blinking in that frequency). When I
    cancel the operation, the HD goes on like that for another 2 minutes or so
    and it is impossible to do anything with the computer. I tried to reinstall
    the computer from the scratch to no improvement. I contacted Seagate again and this time they suggested I use an UATA66 cable, which seems to me a bit weird because I do not think a cable could be a problem given that I am still using the UATA33 mode. Do you have any idea what could be wrong? I have noticed for instance, that the EIDE controller in the Control Panel/System does not have any DMA allocated. Is that not
    supposed to?

  2. #2

    Re: UATA66 with UATA33

    Saw something on one of the overclockers sites about activating DMA, check out overclockers.com, tomshardware.com, and tweak3d.com and you might find something. Seem to remember having to use a patch to acivate DMA depending on which chipset on motherboard, using microsoft drivers not intel or drive manufacturer drivers, and lastly removing the drive from the device manager to be re-recognized by the operating system as a DMA drive. Sounds like you\'ll have to do some digging.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts