I Have a HUGE PROBLEM, so I would be EXTREMLY thankfull if anyone could help me solve it, because my job depens on it !!! I have recently upgraded my system from Win98SE to Win2000 Service Pack 2, because I thought that it would solve the problem with system INSTABILITY and help me achieve low latency with WDM drivers... And the system itself works pretty much OK, BUT one of my main programs - Gigastudio 160 just WONT WORK : To start with, here is my complete system configuration :

Motherboard : ASUS A7V KT266
Processor : AMD Athlon 1.333GHz
Ram : Hyundai 256MB DDR
Soundcard : M-Audio DELTA 1010 with latest WDM drivers
Graphics Card : NVidia G-Force 2 MX400 - 64MB
Hard Disk : Quantum Fireball AS 30GB 7200RPM
Other PCI Cards : Us Robotics 56k int modem, I-will SCSI adapter (for the CD Recorder)

Sonar 2.0 + Gigastudio 2.50.10

And here is the problem : I installed Windows 2000 SP2 (clean install), installed all the latest drivers, installed DirectX 8.1 for Win2000, then Sonar 2.0 and then the Gigastudio 160... and, at first few minutes, I was able to RUN Gigastudio, play the Gigapiano, although it wasn\'t as smooth, as it was with Win98SE, but THEN - THE Real problems started,... I tried to exit Sonar, and it poped up some \"couldn\'t write memory\" messege... and then tried to close Gigastudio, but it CRASHED Like no application has crashed before (at least in my longyear experience)... Giga actually stopped spinning my HARD DISK (with a fiiiuuu sound), poped up a blue screen for a split second (I couldn\'t read what it said) and restarted my computer... SO at the next boot, Win2000 said that it needs to check Hard Disc for consistency, and it found some major FAT32 errors that it (hopefully) repaired... Then I tried to start the Giga again, but it repeated the problem on & on (CRASH, HDD STOP, BLUESCREEN, RESTART THE COMP.)... I reinstalled the whole system by the instructions that TASCAM provided in their \"Optimizing Windows 2000 & XP for Audio\" manual but, it still won\'t work... I tried to do some experimentation with IRQ switching and instaling system in Standard PC mode rather than ACPI mode, but it DOESN\'T WORK !!! SO PLEASEEEEEE !!!!!!!!!!!!!! Can anyone help me solve it cause I\'m getting more desperate every DAY !!! If you need any more info on my config, PLEASE ASK !!! And THANX !!!!