• Register
  • Help
Results 1 to 9 of 9

Topic: Please help with midi recognition problem in GS3

Share/Bookmark
  1. #1
    Senior Member
    Join Date
    Mar 2002
    Location
    New York City
    Posts
    246

    Please help with midi recognition problem in GS3

    For some reason I can't seem to get a midi signal from my Yamaha controller to Gigastudio. GS3 recognizes my Echo Mia Midi card and all of its parameters and I'm pretty sure the midi settings are correct. How should the master setting in the computer be set up? What about within GS3 and Sonar? What should be connected to the GS3 midi and what should be connected to the MiaMidi? I get sound from the program using the onscreen keyboard, just no midi action from my controller. Any thoughts would be appreciated. Thanks in advance.

  2. #2

    Re: Please help with midi recognition problem in GS3

    Are your midi ports in GS3 greyed out or normal?
    Just saw a post that HyperThreading must be turned off in BIOS to avoid greyed out (dead) mid ports using a LAYLA 24.
    Best regards,
    Michiel Post


  3. #3

    Re: Please help with midi recognition problem in GS3

    In GS3 go to File | System Setup and open the hardware TAB. Select the MIA MIDI as the source for GS3's MIDI port 1. That should do it. Try playing on your controller. Also, you might check that you can play GS3 from its graphical keyboard. If that works, you've got GS3 working properly. If the controller still doesn't work, you have some other system problem.

    For Sonar go to GS3's File | GigaStudio Setup menu. Here you can select your sequencer. Sonar is likely in the C:\Program Files\Cakewalk\Sonar folder. Now click the sequencer button on the Giga toolbar and Sonar will open.

    In Sonar you will need to activate the GS3 MIDI ports. I think it's in Options | MIDI devices. Select the GS3 port that you want and move it to the top. Now open a MIDI file or project file in Sonar. Set the MIDI tracks to point to the GS3 port. Play the file, and you should hear the result from GS3 - assuming that you've loaded a GS3 instrument, of course.

    Good luck. (I am away from my system. Some details may have be smeared by my imprefect memory.)

    -JF

  4. #4
    Senior Member
    Join Date
    Mar 2002
    Location
    New York City
    Posts
    246

    Re: Please help with midi recognition problem in GS3

    Thanks for the input. I found out I don't have hyperthreading on my system. Also, I uninstalled Gigastudio and reintalled it. I uninstalled the Mia and reinstalled it. Still not accepting midi from my controller. I can get the midi ports green and active and can create sound using the little keyboard interface on gigastudio but I cannot use my controller. I checked all of the settings in the software and the defaults for windows and they all look like they are correct. Any other thoughts?

  5. #5

    Re: Please help with midi recognition problem in GS3

    This is the most basic recommendation of all, but have you tried another midi cable? Those things go bad all the time, and if everything else is a 'go' that is what I would suspect...

    David

  6. #6
    Senior Member
    Join Date
    Mar 2002
    Location
    New York City
    Posts
    246

    Re: Please help with midi recognition problem in GS3

    I switched the midi cable out with a bunch of different cables. None work. I guess there must be something wrong the with echo midi drivers I am using (but I already uninstalled and reinstalled the software). If anyone is willing to take a look at the diagnostics file I would be grateful. I'm just not sure what else to do at this point.

  7. #7
    Senior Member
    Join Date
    Mar 2002
    Location
    New York City
    Posts
    246

    Re: Please help with midi recognition problem in GS3

    I'm pretty sure both the Mia and Gigastudio are working properly. I think that when I loaded Giga 3 for the first time it erased some Microsoft midi drivers somehow. Is there a way to easily replace these drivers or to see if this is in fact the case? Does DirectX 9 have midi drivers or just audio? Thanks again for any help you can offer.

  8. #8

    Re: Please help with midi recognition problem in GS3

    Windows crunching your MIDI drivers? Oh yeah. That bug.

    This may be what you've been struggling with...

    http://www.rme-audio.de/english/faq/10entrye.htm

    Best of luck.

    -JF

  9. #9

    Re: Please help with midi recognition problem in GS3

    I've been mentioning these tools since I got them a few weeks ago, and now use them constantly: there is a free package called 'midi-utilities-for-windows'

    http://www.sreal.com:8000/~div/midi-...s-for-windows/

    [edit] the forum software squashes the link somehow so here it is
    as a broken url --- take out the space before midi:

    www.sreal.com:8000/~div/ midi-utilities-for-windows/

    No installation is necessary, just unpack them. Then use the command line program called 'lsmidiins' to see what midi in ports windows says you have and 'lsmidiouts' to see the out ports. That alone might show you the problem.

    Then there is a midi monitor you can start up for every port, showing all midi data traveling through the port. They all run in a simple dos window on windows (mine is xp pro, works fine).

    Guglielmo

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •