• Register
  • Help
Results 1 to 9 of 9

Topic: Soanr XL and Kontakt v1.21 Question

  1. #1

    Soanr XL and Kontakt v1.21 Question

    Hi all,

    I just installed Kontakt 1.21 with Sonar XL 2.2 in my home built 3.2ghz Intel PIV computer with 2 Gigs DDR (PC 3200). Kontakt libraries have their own HD. DFD is also installed..

    I am using my Motif 8 Keyboard with the above installation.

    As a standalone, I can hear my voices in Kontakt with no problem.

    When I open Sonar XL 2.2 and insert Kontakt as an DXI, load a voice, I can\'t get any audio.
    I took a Piano track from a previous score (Midi track #1) and tried to substitute a Piano Kontakt voice for it in Soanr and still there is no Audio. I am using the Echo Layla24 and its ASIO driver for the lowest possible latency.

    Any assistance is appreciated.

    Alan Russell

  2. #2

    Re: Soanr XL and Kontakt v1.21 Question

    Couple of things. First, make sure the audio engine for Sonar is turned on. It\'s on the toolbar next to the yellow exclamation point.

    Second, make sure your I/O settings are correct. Midi In can be set to anything. It doesn\'t matter. Out should be set to Kontakt. And, finally, the Ch (or channel) setting should correspond with the midi channel of the instrument in Kontakt you\'re trying to use.

    You can keep your keyboard set to channel 1 all the time, but the channel setting in Sonar must match Kontakt.

    To play a sound -- via Keyboard -- click on the Sonar track that controls that sound.

    Regular playback should be no problem.

  3. #3

    Re: Soanr XL and Kontakt v1.21 Question


    thanks for the reply..

    Tell me where exactly is this: \"\"midi channel of the instrument in Kontakt you\'re trying to use. \"\"

    I was looking for it on the Kontakt sreen..I only saw the \"omni\" setting\"

    Alan Russell

  4. #4

    Re: Soanr XL and Kontakt v1.21 Question

    Double click (or right click -- I can\'t remember which at the moment) on the omni setting you see and choose from a drop down menu of channel settings.

  5. #5

    Re: Soanr XL and Kontakt v1.21 Question


    So the \"Omni\" prompt with all of its channels must coincide with the midi track number you want to hear the Kontakt voice with.

    I had it set to none...therefore, silence prevailed?

    It\'s kind of strange to have an \"Omni\" prompt to be the place to line of the channels here..JMHO..

    Also, I noticed that I can\'t control the volume on the Sonar Console for any of my Kontakt voices when the DXI is employed..Is this normal?

    Any idea appreciated..

    Alan Russell

  6. #6

    Re: Soanr XL and Kontakt v1.21 Question

    In Sonar the \"Ch\" setting must be equal to the channel setting in Kontakt. If Kontakt has piano on channel one, and bass on channel two, then you must set the Sonar track\'s \"Ch\" setting to one in order to hear piano and, obviously, two to get the bass.

    Most things like volume and pan must be controlled via Kontakt itself. At least that\'s my experience. Maybe someone knows how to overcome this.

    Most of the time I lay down the midi tracks, then bounce each one to audio and open the tracks in Vegas 4, where I do the final mix.

  7. #7

    Re: Soanr XL and Kontakt v1.21 Question


    thanks bud..as soon as I get out from my lecture, I\'ll go home and try it and thank you later..

    have a great day!!

    Alan Russell

  8. #8
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: Soanr XL and Kontakt v1.21 Question


    To control volume in Kontact you need to go into the General Options in Kontakt and click the cc7/cc10 option. It is disabled by default.

    When you setup your channel you can set the MIDI in to Omni. Then set the MIDI output to the instance of Kontakt you are using which will be the last ones in the list. Then select your MIDI channel. Also notice that when you add a DXi or VST that an extra audio channel is added at the bottom of your tracks. Make sure you select which output you want to send each instance out of. In Kontakt you need to set what channel your instrument is on in Sonar so you can play independent sounds on each channel.

    There is a nasty tempo bug in the DXi version of Kontakt. When you add tempo changes to your piece after recording your parts, the note lengths will be all screwed up. I recommend getting the VST Wrapper and using the VST version of Kontakt which resolves this very annoying issue. The VST wrapper will also allow you to use other VST plugins. Sonar 3 includes the VST wrapper.

  9. #9

    Re: Soanr XL and Kontakt v1.21 Question


    thanks for the master volume advice...I will try it shortly.

    Can you help me with the other thread next to it..

    (creating a .wav file from my midi sequence in Sonar using Kontakt as a DXI..)

    many thanks..

    Alan Russell

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts