• Register
  • Help
Results 1 to 6 of 6

Topic: Giga Piano not recognized on install

  1. #1

    Giga Piano not recognized on install

    During the install of Giga Studio on my machine, at the time of registration, I am asked to insert the Giga Piano CD. Although I do insert it, I am unable to get GigaStudio and I have to abort registration.

    PS : My CD-ROM is a SCSI CD-ROM.

    Has anybody had the smae problem ? What is the solution ?

  2. #2

    Re: Giga Piano not recognized on install

    Some bad piano CDs went out, and apparently the piano CD has some registration stuff on it.

    Nemesys actually have a URL for getting a fresh CD if yours is bad.

    From Joe @ Nemesys::

    We (NemeSys) have identified a problem with a batch of CDROMs manufactured last month. We have corrected the problem. Unfortunately, some of the CDROMs made it into product. To obtain a replacement CDROM please visit

    and fill out the form.
    It will ask for
    Your Name
    GigaStudio CD Key
    Shipping Address
    Name of the Corrupt CD

    We apologize for any inconvenience.

    Joe (NemeSys)

  3. #3
    Senior Member LHong's Avatar
    Join Date
    May 2000
    San Jose, Ca, USA

    Re: Giga Piano not recognized on install

    Well, I have a same problem, even now I\'ve the 2nd-CD replacement, it\'s even worse. I couldn\'t even re-launch the gigastudio! anyone knows why? I\'m thinking because the giga might not always works with different CD-RW manufacture DRIVER! next thing I would try other CD-R...It\'s driven me crazy. Now I have to re-install the GigaSampler and it notes me that I have to re-register due some memory expansion has changed in the system (I guess). I think that Nemesy must looks into these problems. It is generating many in-inconveniences to us. I understand that Nemesy must has some way to protect the software which is to avoid any illegal copies...But you see how many users have same problems...I don\'t beleive it is in a GigaPiano problem (Corrupt CD). I would put a good bet on this, Nemesy. Any ideas?

  4. #4

    Re: Giga Piano not recognized on install

    Hi - I sent this information to Dave @ Nemesys, and they\'re evaluating it now. It worked for me, but may not work for you, and use caution, because it involves editing the registry.
    I may have found a solution to a percentage of the \"Your CD2 was not found\" support issues.

    This involves the \"verification\" check of the 2nd CD during product registration *after* program setup has completed.

    The registration process presents the user with the data that the user input during setup for visual verification, and then requests that the 2nd CD be placed in the CDROM. It\'s at this point that you can get a failure because of the way the registration process searches for the CDROM drive.

    The registration process apparently uses data stored during the setup process at:

    HKEY_LOCAL_MACHINE\\.DEFAULT\\Software\\NemeSys\\G igaStudio\\Settings\\CompMgr_CdDrv_x, where \"x\" is the supposed drive letter of the machines CDROM drive.

    Unfortunately, the value in not always correct. During GSt Setup, the Setup process apparently takes the first instance of a particular CDROM at the key:


    which may or may NOT be the currently installed CDROM. The example below was taken directly from a registry where this key had multiple installation instances. Some entries have been truncated for clarity.


    [HKEY_LOCAL_MACHINE\\Enum\\SCSI\\HP_CD-WRITER+_8100_1\\MF&CHILD0001&PCI&VEN_1106&DEV_0571 &SUBSYS_00000000&REV_10&BUS_00&DEV_04&FUNC_0110]
    \"DeviceDesc\"=\"HP CD-Writer+ 8100 \"

    [HKEY_LOCAL_MACHINE\\Enum\\SCSI\\HP_CD-WRITER+_8100_1\\MF&CHILD0000&PCI&VEN_1106&DEV_0571 &SUBSYS_00000000&REV_10&BUS_00&DEV_04&FUNC_0110]
    \"DeviceDesc\"=\"HP CD-Writer+ 8100 \"

    [HKEY_LOCAL_MACHINE\\Enum\\SCSI\\HP_CD-WRITER+_8100_1\\MF&CHILD0001&PCI&VEN_1106&DEV_0571 &SUBSYS_00000000&REV_10&BUS_00&DEV_04&FUNC_0100]
    \"DeviceDesc\"=\"HP CD-Writer+ 8100 \"

    Apparently, the GSt Setup program takes the first entry it encounters to create the \"CompMgr_CdDrv_x\" data. In the case of these registry entries, the value was \"F\", which in this case was incorrect. The correct entry was the 3rd entry (labeled \"Driver\"=\"CDROM\\0003\"). The value for \"CompMgr_CdDrv_x\" should have read \"CompMgr_CdDrv_E\" rather than \"F\".

    The way to identify if you\'re experiencing the anomalous behavior is to watch the CDROM when the CD2 verification process is taking place. If the CDROM access indicator lights during this process, and fails, then you most likely have a defective CD2. If it does not light, and goes directly to the \"We can\'t find your CD2\" screen, then you\'re experiencing this problem.

    The way I resolved this issue, which may or may not work for you, was to delete the multiple instances of the same CDROM at the HKLM\\Enum\\SCSI\\<CDROM> key, leaving the most recent. Note that each entry has a \"Driver\"=\"CDROM\\\\000x\" entry. I just deleted all but the most recent. This will work if you haven\'t changed the configuration of your system to the point where another one of the entries is valid again. If these deletions don\'t work, then delete the entire key for a given CDROM, and let it be re-detected.

  5. #5
    Senior Member LHong's Avatar
    Join Date
    May 2000
    San Jose, Ca, USA

    Re: Giga Piano not recognized on install

    SteveMitchell and Eschalit,

    It works now! Thanks for the TIPS.

    You are right, the problem on the CD-DRIVE LETTER. The giga was confused when I\'m having multiple setups in the CD-DRIVER\'s REGISTRY (same place as you mentioned). I just deleted them and kept only current one like \"CurrentDriveLetterAssignment\"=K\" which is matched with the hardware now.
    And now giga is happy to read it!

    What I understand about the issue is that I have the \"D\", \"E\" and \"K\" in the registry, it is a result of two times I added the hardrives and it was added more lines to it, due in updated the CD\'s letter to currents, same thing if you have changed the HARDDRIVE partitions. The conclution for Giga to read the CD#2 is that to make sure everything in the REGISTRY where is SteveMitchell has shown (follow his instruction and caution as well). I\'d like to add some word is: \"deleted the multiple CD-DRIVE-letter, only keep the current one\". Maybe your case can be different behavior? but it works for me!
    It was a pretty good lesson for me like to work in the dark for two months. This kind of problem would takes Nemesy forever to re-produce it, why? most of the developers don\'t test many custom setups in the system like what we have, they don\'t realize how much hasles that we have gone through for dealing with the PC hardware from left to right for best taking advantage such as Memory, CPU, harddrive and even the mother-board...And now to deal with the Giga installation and registration.

    Back to the giga registration, if you change any hardwares in the system (add more harddrive, add more memory, change video card, etc), you need to re-register it! Am I correct? why to make our life is difficult than what it supposes to be...I don\'t know how good the giga-software is but the installation is a basic step, it must be very friendly to get start. I want to know how you (Nemesy) feel it if in the moring whenever you couldn\'t start your new car or your new car is broken-down on the street? then probably you should realize that how important it is. Why people\'s usualy made a mistake on simple thing? I don\'t expect a perfect software without bugs, but this kind of bug is not acceptable! Nemesy.

    One more problem is inside the GigaStudio project, it still doesn\'t reconize the CD (wrong format). It is not a big deal for me since I did copy all my 20 CDs to the harddrive already...of course I\'d like to hear the solution for it!
    Hope that I can spend more time on the music rather than on this software problems.

    Thanks again, SteveMitchell,
    Good lucks, Eschalit,

    [This message has been edited by LHong (edited 09-12-2000).]

  6. #6

    Re: Giga Piano not recognized on install

    You and I have been going through the same thing man! I got mine fixed today because of what you said. It was reading my F Drive as Drive M! So Kevin at Nemesys had me go into Gigastudio and change it to F Drive, now it works.
    I too, still get \'format unknown\' when I put the piano CD in on the Gigastudio Port one window but it reads my akai S1000 CD fine. I just don\'t know whether to buy Gigasampler or Akai Cds. I\'m afraid it might not be able to read the gigasampler Cds since it still can\'t read the gigapiano.
    Keep me informed if you hear of any other news on this issue.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts