View Full Version : Patch Change (program change) not working in Gigastudio?

11-21-2006, 04:13 AM

I just installed latest 3.20 update. Trying to play some old sequences in DP 5.1 with their corresponding Giga performances (built with 2.5) they aren't working! The problem are the program changes. They're just ignored. Sometimes it seems to work, but then not. In some channels they NEVER work. The MIDI messeges that were programmed in Performer were just simple program changes (not + bank, or nothing complicated). With Gigastudio 2.5 it worked flawlessly! Doing some searches around Giga forums I realized that maybe the program changes never worked in Giga 3!!! Because I started to use some other techniques for programming (keyswitches) this maybe problem just passed unseen by me.

One note: if you select "Program Change" as the quick controller in the instrument slot in Giga 3 (where you normally see "Volume"), when the program changes are transmitted from the sequencer you can see this parameter changing, but the corresponding loaded instrument (with the apropiate program number) doesn't get selected! Weird! I also tried to change programs from my keyboard controller. The same happens. Sometimes (less than more) it works, sometime not at all!

Any input welcome, thanks!!!