PDA

View Full Version : No sound from new Kontakt 2.2.0.005 player!



spitfire31
12-05-2006, 01:37 PM
Hi,

Just downloaded and installed the new, updated NI Kontakt player on my Mac G5 2x2.3/10.4.8.

Everything works smoothly. Except: no sound at all!

Yes, MIDI is incoming and the MIDI indicator flickers, CPU and disk acitivity meters move (but not the audio level meters), the correct audio output is selected, I've kicked up CC#11 and seen the MIDI indicator respond, I've tried Strad 1.08 and 2.01 both.

No sound, period.

Since everything else works, I assume I don't have to re-authorize?

And guess what? Both Strads work just fine in my Kontakt 2.1.1 (I haven't dared go to 2.2 since my current setup works quite well).

Help!:wow:

/Joey

Giorgio Tommasini
12-05-2006, 03:14 PM
Joey,

I downloaded and tested Kontakt Player, vers. 2.2.0.005 with the Stradivari vers. 1.08 and 2.01 on a PC. Everything works correctly.

Anybody else is getting this problem on a mac?

Sincerely,

Giorgio

Nickie Fønshauge
12-05-2006, 03:17 PM
Is your Audio Setup still configured correctly? And what about the Output channels? I was thinking, maybe the updater changed something here.

spitfire31
12-05-2006, 03:47 PM
Good evening Nickie, Giorgio,

Thanks for taking an interest in my problem.

Yes, I definitely have my audio system set up corrrectly (Metric Halo 2882 MI/O) – Kontakt 2.11 plays Strad just fine, as I mentioned, with the same settings. I also tested with the Mac internal sound engine. And, even if I had made a set-up mistake, shouldn't the Player level meters come alive?

Anyway, to make absolutely sure, I loaded the Kontakt AU Player into RAX; still no audio (and not even the tiniest flicker from the Kontakt Player output level meters, nor from those of RAX). So, I loaded another sampled instrument into the same RAX slot (AraldFX Grand Electrix), and I can hear it loud and clear.

The problem is somewhere else, I fear. I also repaired permissions (nothing to report) and made a hard restart (switched off, waited a couple of minutes, switched on). No change in either .

So...?

Best,

Joey

vic_france
12-05-2006, 05:23 PM
Working fine on Mac here, both as Standalone and as VSTi in Cubase 4.
I would suggest you completely reinstall Kontakt Player 2 (remove application, plugins and preferences first, so that the installer does a "clean" install rather than overwriting).

spitfire31
12-05-2006, 05:56 PM
Hi Vic,

Another DP user... ;-)

Thanks for your suggestions! I did just that – threw out everything Kontakt 2 Player I could find, including .plists and VSTs/AUs; reinstalled.

No dice – same thing exactly. The GUI shows all the signs of being active, the Reference tone and the Metronome both sound, but the instrument output level meters show nothing.

Could there be some kind of conflict between Kontakt Player 2.2 and the full Kontakt 2.11? I'm not planning to update to Kontakt 2.2 yet – too much voodoo flying around. Guess I'll just have to forget about the Player for the time being and run Strad in Kontakt, without the attack pitch deviation in 2.01, though. :(

Best,

Joey

vic_france
12-05-2006, 06:32 PM
(apologies if this is preaching to the choir! :) )...
I presume you have selected an appropriate keyswitch (e.g. C1)?

Btw, Strad 2 is also working perfectly for me in Kontakt 2.2

spitfire31
12-05-2006, 06:40 PM
Hehe, just by coincidence I stumbled across the thread The Silent Stradivari Syndome above...

So I did double check that (I've been known to do dumber things). But, if no keyswitch is active, the various voice, polyphony, CPU, disk activity, etc. indicators in the GUI are also inactive, except for MIDI IN. In my Player 2.2, all indicators are 'live', except for the output level meters.

So, Player 2.2 is doing everything right, except pipe audio to Core Audio...

Best,

Joey

Giorgio Tommasini
12-06-2006, 03:18 AM
Joey,

As you know, the Silent Stradivari Sindrome was caused by inappropriate dlls, erroneously included into the Player by NI. They were installed only if no dlls of the same type were present.

On the other hand, you said that the Stradivari was correctly working with the previous version of the Player. This would mean that wrong dlls were reinstalled with the latest version. Other users would be presumably affected as well. Anyway, you may easily check this hypothesis by downloading the working dlls from:

http://www.garritan.com/Strad/Stradivari_system_extensions.zip.

Best regards,

Giorgio

spitfire31
12-06-2006, 03:28 AM
Good morning Giorgio,

Thanks for your continued attention! Sorry, my reference to the Silent Strad Syndrom thread was just that one user had apparently disabled all the keyswitches by mistake and found that that was the cause of his silent Strad. Short circuit, between the ears, if you will; I've done many mistakes like that, but not this time.

And sorry again to appear like a newbie - what is a "dll"? I'm on a Mac, as I mentioned in my first post.

Best regards,

Joey

vic_france
12-06-2006, 08:29 AM
Hello again Joey,
(really just shooting in the dark here...)
Try sending "CC#7=127" into the Kontakt Player.

spitfire31
12-06-2006, 09:41 AM
Vic,

Thanks for your persistence! CC#7 is received (level slider moves fully right) but still no sound. I'm contacting NI Support (I have a rather good experience of them, as a matter of fact).

Thanks again,

Joey

Giorgio Tommasini
12-06-2006, 10:10 AM
I'm on a Mac, as I mentioned in my first post.


My apologies Joey. Must be kinda tired. :)


Giorgio

spitfire31
12-06-2006, 06:42 PM
Solved! *()

I re-installed Player 2.2.005 yet again (fourth time?), and now I can hear the Strad!

What did I do differently?

I used the default installation, instead of (as I did every time before) deselecting the RTAS plug (since I have no use for it).

Obviously a minor bug, but probably something most people would never come across (everybody here running ProTools?)

So, thanks to everybody who came with suggestions, everything OK now.

Best,

Joey

vic_france
12-06-2006, 07:18 PM
Happy for you :)
(but that's a bug that definitely needs fixing... quick!)