View Full Version : Cakewalk/Gigasampler

07-14-1999, 01:50 PM
OK, after tearing my hair out for a few days, Gigasampler now works fine on my machine, at least as long as video acceleration is disabled.
But, now cakewalk is experiencing pops and clicks while playing back audio, whether Gigasampler is running or not. This behavior has occurred only since installing GS. Previous to installing GS, I could play back 8 tracks of audio with real-time effects with no clicks/pops. The clicks and pops are present regardless of which of my two soundcards I use for playback.
My WILD THEORY is that Gigasampler has some background process running which perhaps is conflicting with Cakewalk\'s audio playback.

Any ideas???

Setup information:

Asus P2B
Celeron 400
128 MB PC100 SDRAM
STB Velocity 4400 (TNT)
SB Live w/ add-on card
AWE-64 Gold
Western Digital 6.4 GB IDE (Operating System)
Maxtor Diamond Max Plus 20.4 GB (Audio)
Generic PCI ethernet card
USR 56K Modem (Wave driver disabled)

Windows 98
Cakewalk 8.0 Professional
Gigasampler LE

Dave Of NemeSys
07-15-1999, 02:26 PM
A couple things. The STB cards have been known to drag the audio down at times. Also, if you just want CAkewalk by itself without the GigaSampler Endlesswave driver running in the back ground, just go to MIDI devices and un-highlight it. When you want to use the GigaSampler again, re-highlight it.
Celerons seem to be working ok for most people but they are not garanteed or tested. Adding hard disk audio recording and playback to this will tax the system also. It\'s possible to do all this on a single machine but both the GigaSampler and the Sequencer audio polyphony may be reduced.
Take care
Dave of NemeSys

07-22-1999, 02:38 PM
I am hesitant to add anything to Dave\'s reply since he is from Nemesys, but I have been having the same problem and it is even worse since I upgraded to Windows 98 and ordered the latest version of Cakewalk. The only way I have found to completely get Cakewalk to function normally (with regards to dig audio) is to go to the Close Program dialogue in windows (using CTRL + ALT + DEL) and close Msgloop and Msg32. Of course at that point, you can\'t run Gigasampler. (But at least you get your full Dig Aud features back in Cakewalk.) Dave, if you or anyone else has any further ideas on this, please let me know. I am not that interested in being able to record dig audio while using GS, but to be able to play Dig Aud from Cakewalk is a real necessity, ESPECIALLY if I want to maximize the capture feature of GS. If I have misunderstood something, please let me know.

PaPa Chalk
07-22-1999, 03:43 PM
Very Strange You have a similar setup to us here. Only difference is our sequencing software. Cubase Vst 3.7 rock Solid as I Post. I have Cubase Vst triggering GigaSampler right now while I\'m posting this.
I setup my Sb live as the wave device for GigaSampler. Then in cubase I have Sb live also as my main output device. Make sure in windows control panel you go to audio Hq.
Then device controls. On the wave tab set maximum simultaneous playback to 4 or more. this means you will be able to use 4 or more applications at the same time with the live.
This may help if not it may be a cakewalk issue. We are having much success with Vst 3.7. I\'d like to test logic also to see if We can get the same results.

PaPa Chalk

[This message has been edited by PaPa Chalk (edited 07-22-1999).]

[This message has been edited by PaPa Chalk (edited 07-22-1999).]

07-23-1999, 10:09 AM
Thanks for the replies.
I\'d like to try a different sequencer, but since I just shelled out $170 for Cakewalk, I\'m a bit hesitant.
Like Joel said, I don\'t need to use Giga and CW digital audio simultaneously (although that would be cool...) but I DO need to use digital audio in cakewalk.
Is there a way to set up the GS vxd\'s to not load at startup, and manually load them later???
I\'m 99% sure this is a software compatibility issue between GS and CW, since I have tried different driver versions, and tried installing CW and GS on a fresh Win98 test install on a new hard drive. (I really want this to work!), and CW worked fine before.


PaPa Chalk
07-23-1999, 10:47 AM
There are other users who are sequencing with cakewalk also sme people at nemesys also.
Try contacting them they may be able to help you if its an issue with gigasampler and cakewalk.
it could be just configuration.

Papa Chalk

07-26-1999, 05:01 PM
Redeye. . .did you try experimenting with the
buffer size under tools/audio options/ advanced I have mine set to 8MB and experience very few prblems without having to close the endless wave drivers. . .good luck


Dovi Engler
07-27-1999, 05:33 AM
Some of our customers are happy with GS and
CW working on the same computer.
We need some more information for your setup.
Does your Celeron is typeA (w/cache)?
Are you runing GS LE Ver.1.52?
Which card is used by the GS?
Basicaly on a PII 300 with 128MB RAM, UDMA hardisk, CW8.03 and GS1.52 runing on AWE64 Gold, we tune the CW for 4 Rec Buffers & 8
Playback Buffers 16KB each.

Good Luck...

07-27-1999, 01:08 PM
OK, I\'ll try experimenting with the buffers.

More info:

My Celeron has on-die cache. (All of the 400\'s do I believe).

The pops occur with either sound card (AWE64 or SB Live).

I\'ve removed GS from my system because I need to do some audio recording. I\'ll reinstall it and try these things.


Bob Campbell
07-27-1999, 02:50 PM
I have a couple of recommendations which you DEFINITELY should try.

1) It is not the STB card that is at fault, it\'s the STB drivers. If your card is a TNT you can use Detonator drivers. Get the latest from www.nvidia.com (\"http://www.nvidia.com\")
(i have a Diamond Viper V550 TNT, and with their driver applet, I can\'t get audio progs to work properly - fixed with the detonators.)

2) Dave from Nemesys won\'t want me suggesting this, BUT, I had a major problem getting my sequencer (VST) to trigger Gigasampler. I was convinced it was an Audio card driver problem (i have an Aardvark so there should have been NO problem!). After lots of mucking around I came to the root of the prob. The Gigasampler MIDI driver. I and installed Hubi\'s midi loopback instead.
Since then, absolutely perfect performance with VST and GIGA working alongside.

So, I suggest you at least try Hubi\'s if you have this problem. There\'s no need to uninstall any part of Gigasampler. Just disable the GS driver in your sequencer (make it inactive in Cakewalk/Cubase preferences), and replace it with HUBI\'s.

Hubi\'s midi loopback is freeware, look for it on the web. It is a generic internal Midi driver for windows that works much the same way as the Gigasampler midi driver. e.g. you choose LB1 as the output midi port for a track in your sequencer, and choose LB1 at the receiving end (Gigasampler\'s Midi input).

If you have any questions about trying this, post another message.


p.s. I forgot to say, try the video driver thing FIRST, it could be the real reason for your probs. Secondly, if you find that using Hubi doesn\'t fix the problem, you can actually stop the Gigasampler Endless Wave midi driver from loading into Windows at all, and this may fix things. Ask me if you need to know how to do this. Thirdly, you may not belive this, but your whole problem MAY (i stress may) be being caused by your Modem, especially if it is a USR modem. Some people have to remove their modems to get audio things sorted (it\'s something to do with the way the Modem\'s drivers run in the background and do some kind of system polling thing, constantly interrupting your audio stream).

Hope I have been of help.

[This message has been edited by Bob Campbell (edited 07-27-1999).]

Mark Ellis
07-31-1999, 09:00 AM
Hey Bob, I have a Viper 550 as well. Can you tell us a little more about the Detonator drivers? I searched NVidia\'s site, but they don\'t seem to have Win98 drivers. I\'d like to try them, any ideas?

07-31-1999, 09:36 AM
Just wanted to follow up on my earlier message. I have sinced received my 1.52 update from Nemesys and that FIXED my streaming audio problems between CW and GS. Hope this might help someone else.


[This message has been edited by Joel (edited 07-31-1999).]

08-09-1999, 10:36 AM
Version 1.6 fixed this problem completely!
Woo Hoo!