View Full Version : GPO Studio impossible to use with MOL?

07-11-2004, 03:42 AM
Since Logic 5.5 (PC) doesn't play nice with GPO VST, I've been trying to use Midioverlan to run GPO on a second machine (GPO machine has WinXP with Delta Audiophile2496). However, routing to a rack of GPOs with Midioverlan seems impossible. Has anyone gotten this to work?

1. Tried running multiple copies of Garritan personal orchestra standalone on the GPO machine. Can't get more than one instance to use the Audiophile's output drivers.

2. Tried using the "Echo To" option in Midioverlan (on the GPO machine) to forward the incoming Lan-In midi to the GPO Studio channels, but the Echo To option seems to only work while the Midioverlan control panel is open and MOL will only echo from the currently selected "Midi from Lan" device in the control panel (so I can only Echo to a single GPO Studio channel at a time). For example, to get Lan-In 01 to echo to GPO Studio 1, I have to have the "Lan-01 In" options screen visible in the Midioverlan control panel. This makes sequencing more than one GPO rack impossible.

3. Tried using the "GPO Studio Midi Inputs" (Two computers) tool that comes bundled with GPO. The tool won't recognize the Lan-In channels from Midioverlan, so there is no way to connect them to the GPO Studio channels.

It seems odd that the GPO routing tool won't see the MOL drivers, even though they are clearly installed and can be recognized by both Logic and Gigastudio. Any help would be much appreciated.


07-12-2004, 01:09 AM
As an addendum, The GPO studio midi inputs will also not successfully route midi to GPO Studio using

1) a midisport 1x1
2) the Delta Audiophile Midi In

I know the midi is coming into the computer because a single instance of GPO responds to the incoming midi, but GPO studio (using the GPO Studio Midi Inputs tool) cannot. The GPO studio midi tool finds the midisport 1x1 and Delta AP inputs (they are in the dropdown menus for each GPO instance), but the midi never reaches the GPO instances.

I tried using the "GPO remote" utility in the downloads section of Gary's site... Maple midi driver working, LAN connection working, GPO studio running, client and server tools open and "connected" from what I can tell, but no midi getting to GPO studio.

Furthermore, GPO studio crashes 100% of the time on exit:
AppName: personalorchestrastudio.exe
AppVer: ModName: msvcp60.dll
ModVer: 6.0.8972.0 Offset: 00001a9d

-Matt Emery

David (plogue)
07-12-2004, 06:14 AM
Furthermore, GPO studio crashes 100% of the time on exit:
AppName: personalorchestrastudio.exe
AppVer: ModName: msvcp60.dll
ModVer: 6.0.8972.0 Offset: 00001a9d
-Matt Emery

Hi could you send me your personalorchestrastudio.log file?
(in the Studio install dir)
please send it at davidv at plogue.com
Itl help us diagnose whats going on.


Jeff Hurchalla
07-14-2004, 01:56 PM
Hi Matt,
I order to use the GPO Midi Inputs tool, make sure all applications on your system are closed and then start the GPO Inputs tool. Then start GPO Studio. It will probably be easiest for you to start testing it out by using your MidiSport interface with your keyboard controller. I would suggest for you to start with using just the first port and first channel. Load an instrument in GPO Studio on the first player and first channel and verify that you are able to get sound. Once you get this to work, you can try MidiOverLAN. There is a simple trick that lets you use MidiOverLan (there is something unique about the MOL drivers that cause it to be the only driver I've ever heard of that doesn't show up). For the Midi Inputs tool, right click to get properties, and set the Compatibility Mode to "Windows 2000". After doing this, when you start the midi inputs tool, the MOL driver ports should show up.

10-14-2005, 01:57 PM
I was just hunting and found this old post. Has anyone managed to get Midi Over Lan to work with GPO Studio running on a Mac? Thanks for any help!
- robjohn